Table of Contents

Previous

Next


Adjusting the HTML Help Viewer Window Size and Toolbar Buttons

To modify the default HTML Help Viewer window, you need to override the default template.hhp file. This file provides the default HTML Help project options and drives the changes specified through the ePublisher options and settings. You can modify various aspects of the default HTML Help Viewer window definition through HTML Help Workshop. For more information about the window definition settings, see the HTML Help Workshop help.

This template file is used to create the .chm file for each top-level group in your project. If you have multiple top-level groups, ePublisher applies these settings to the .chm file for each top-level group.

To change the default Help Viewer window size and toolbar buttons

  1. In Windows Explorer, open your project folder. For more information about override files and locations, see “Understanding Stationery, Projects, and Overrides” on page 327.

  2. If you want to override the default HHP settings for 'all HTML Help targets' in the 'project, create the Formats\Microsoft HTML Help 1.x\Pages folder in your project folder.

  3. If you want to override the default HHP settings for a specific 'target, create the Targets\targetname\Pages folder in your project folder, where targetname is the name of the target you want to override.

  4. Copy the template.hhp file from the following folder to the override folder you created within your project folder:

Program Files\WebWorks\ePublisher Pro\Formats\Microsoft HTML Help 1.x\Pages

  1. In HTML Help Workshop, open the template.hhp file you copied to your project override folder.

  2. On the Project tab, double-click on Tripane=”” under [Windows]. HTML Help Workshop displays the Window Types window, which allows you to adjust the Tripane window definition.

  3. If you want to adjust the default window size and position, complete the following steps:

  4. On the Position tab, click Autosizer.

  5. Adjust the size and position of the sample window to match how you want the default HTML Help Viewer window to open.

  6. Click OK to define the size and position values based on the sample window.

  7. If you want to adjust the buttons included in the toolbar pane, on the Buttons tab, select the buttons you want to include in the toolbar pane. For more information about a field, click the question mark icon, and then click the field for which you want more information.

  8. Click OK.

  9. On the File menu, click Save Project.

  10. On the File menu, click Exit.

  11. Regenerate your project to review the changes.

ePublisher/2008.3/Help/Designing_Templates_and_Stationery/Customizing_Stationery.4.24 (last edited 2008-10-11 06:32:59 by BenAllums)