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The WebWorks ePublisher Platform Documentation

The WebWorks ePublisher Platform provides many resources to help you use the product 
components to deliver integrated, single-sourced information solutions:

Evaluation Guide
Provides general information about the product and guides you through the trial and 
evaluation process.

Design Guide
Provides strategy and best practice information for designing and deploying 
standardized Stationery for information development teams to use. This book 
defines terminology and provides the concepts and procedures you need to achieve 
the look and feel you want for your information deliverables. This book also 
outlines how to automate the publication process.

Writer Guide
Provides the information you need when developing content to publish. This book 
provides the concepts and procedures you need to create the source files and then 
publish those files using a defined Stationery.

Help
Provides context-sensitive information and step-by-step guidance for common 
tasks, as well as descriptions of each field on each window. The Help provides a 
comprehensive, integrated deliverable that includes all the information from the 
books. To display the Help, click Content on the Help menu in the console.

Contacting Quadralay

Please contact us with your questions and comments. We look forward to hearing from 
you. If you need assistance with an issue, please contact Technical Support. The Support 
Web site allows you to review the support policy and create a case to track an issue.

Telephone: 877.893.2967 (only in the United States and Canada) 
512.719.3399

Email: info@webworks.com

Support www.webworks.com/Support

Web Site: www.webworks.com
Evaluation Guide The WebWorks ePublisher Platform Documentation  vii
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Conventions

The WebWorks ePublisher Platform documentation uses consistent conventions to help 
you identify items. The following table summarizes these conventions.

Convention Use

Bold • Window and menu items

• Technical terms, when introduced

Italics • Book titles

• Variable names

• Emphasized words

Fixed Font • File and folder names

• Commands and code examples

• Text you must type

• Text (output) displayed in the command-line interface

Blue • Links

 > • Submenu selections, such as Generate Reports > All

Brackets, such as [value] • Optional parameters of a command

Braces, such as {value} • Required parameters of a command

Logical OR, such as 
value1 | value2

• Exclusive parameters. Choose one parameter.
viii  Conventions Evaluation Guide



Evaluation Guide Chapter 1: Introduction to the WebWork
1
Introduction to the WebWorks 
ePublisher Platform

Content development, publication, and maintenance are complex, time-consuming 
processes. Each day, companies spend numerous hours writing, formatting, and publishing 
information needed by internal and external users. At the same time, these users search 
among vast amounts of content to find the information they want and need. Companies 
need to streamline content production processes while delivering the content to users 
when, where, and how they need it.

Adding to this complexity, teams across the company use multiple content authoring tools, 
such as Adobe FrameMaker, Microsoft Word, and XML editors, to create the content. 
These teams must be able to use the authoring tools that best meet their needs. However, 
mastering these tools for content development is only half the battle. Content developers 
also need tools to publish content consistently in multiple formats, such as print, HTML, 
and PDF. This requirement is difficult to meet and often leads to increased production 
costs or an inconsistent corporate image. In addition, corporate branding standards change 
over time, and implementing these changes across all content adds to production and 
maintenance costs.

With all these variations in content creation, publication, and maintenance, delivering the 
right information to the right people in the right format and at the right time is an endless 
and costly struggle that consumes enormous time and resources across organizations.

What Is ePublisher?

The WebWorks ePublisher Platform (ePublisher) is a powerful, comprehensive solution 
that delivers cost-effective processes for efficiently publishing and maintaining online and 
print information. ePublisher gives you the flexibility to deliver content from multiple 
types of source documents, such as Adobe FrameMaker, Microsoft Word, and DITA, in 
virtually any output format you need without incurring training or software deployment 
expenses. The open, standards-based architecture provides a powerful engine that does not 
lock your content in a proprietary format that can become outdated as tools and standards 
change.
s ePublisher Platform  1



What Is ePublisher?
With the robust combination of input and output formats supported by ePublisher, you can 
develop the content using your preferred content authoring tools, and then produce and 
maintain all your deliverables within a single publishing environment. You can implement 
a consistent look and feel across all deliverables and quickly modify and deploy that 
branding if and when needed. ePublisher integrates seamlessly with your content 
management or version control systems, so you can automatically generate and deploy the 
deliverables you need and reduce the time demands on your teams.

Workflow

WebWorks ePublisher Platform components provide a workflow that ensures you can 
deliver your content your way every time. A successful online content delivery workflow 
includes the following items:

• Creation and automation of consistent, reusable online content designs

• Packaging of online content designs for seamless, consistent reuse

• Application of online content designs to new and existing projects to ensure 
consistent content delivery and deployment

ePublisher supports this workflow by allowing ePublisher users to perform the following 
tasks:

• Stationery designers use ePublisher Designer to create and manage online content 
designs, then package the designs into Stationery for writers to use

• Writers use ePublisher Express and Stationery to create and deploy consistent 
online content

• ePublisher AutoMap can be configured to automatically generate and deploy online 
content

For more information about the WebWorks ePublisher Platform components that support 
this workflow, see “WebWorks ePublisher Platform Components” on page 2. For more 
information about the ePublisher workflow, see “Understanding the ePublisher Workflow” 
on page 45.

WebWorks ePublisher Platform Components

With ePublisher, you can write your content in your preferred authoring tools, then use 
ePublisher components to design and deliver your content. The ePublisher components 
allow you to design all the content output formats you need, and then automate the 
publication process and integrate it with your company-wide processes, such as product 
builds and Web site updates.

ePublisher includes the following components:
2  Chapter 1: Introduction to the WebWorks ePublisher Platform Evaluation Guide



What Is ePublisher?
ePublisher Designer 
The design tool for creating and designing Stationery. Stationery defines the 
appearance and functionality of all the output formats you need. ePublisher 
provides several default formats that you can use as a basis for your Stationery, and 
then you can customize that standard and save it as your Stationery for your 
deliverables produced using the other ePublisher components.

ePublisher Express
The on-demand publishing tool that transforms your content based on your 
Stationery and converts your source documents into the desired output formats. 
This component is installed on the desktop and integrates with your existing 
authoring tools to support the features you require, such as related topics and 
expand/collapse sections within your deliverable. With this component, you can 
quickly prepare your source documents and generate your final deliverables.

ePublisher AutoMap
The automation tool that enables you to automate the content conversion process, 
batch processing, and integration with content management or version control 
systems. This component lets you schedule conversion projects to occur at times 
when you are not using your computer. For example, you can schedule the 
conversion to occur overnight. Then, when you arrive the next morning, your 
transformed content is ready for you. You can also automatically generate and 
deploy deliverables to meet your specific needs, such as updating Web site content 
based on updated source documents.

Supported Input Formats

ePublisher provides a single-sourcing environment that works with several input formats, 
such as Microsoft Word, Adobe FrameMaker, and tools that support DITA authoring.

Please refer to the following website for the list of input requirements:

http://wiki.webworks.com/Permalinks/Solutions/Input/InputRequirements
Evaluation Guide Chapter 1: Introduction to the WebWorks ePublisher Platform  3



How ePublisher Helps You
Supported Output Formats

ePublisher lets you define your output formats, such as XHTML and WebWorks Help, so 
content developers can focus on developing quality content without worrying about 
tedious conversion requirements for various deliverables. You can manage your content as 
you want and produce deliverables in the following formats:

• HTML 3.2

• XHTML 1.0

• XML+XSL

• Wiki Markup

• WebWorks Help

• WebWorks Reverb

• Microsoft HTML Help

• Microsoft WinHelp

• Eclipse Help 

• Sun JavaHelp 1.1.3 or 2.0

• Oracle Help

• PDF

• PDF - XSL-FO

• Microsoft Reader

• Palm Reader

• eBook - ePUB 2.0

How ePublisher Helps You

With ePublisher and its agile enterprise publishing capabilities, you have unparalleled 
design flexibility with the ability to deliver your information, regardless of input format, in 
multiple output formats. This solution enables both large and small organizations to 
implement the publishing environment that works best for them.
4  Chapter 1: Introduction to the WebWorks ePublisher Platform Evaluation Guide



How ePublisher Helps You
Streamline and Automate the Content Publishing Process

In a traditional content authoring environment, a content author produces content designed 
for a single output format. This environment typically has the following limitations:

• Content is often duplicated across multiple content-producing teams.

• Content is not maintained consistently across the multiple teams.

• Production is expensive with multiple tools and technologies.

Using ePublisher, you can quickly publish content from your source documents. You can 
develop the content using your preferred content authoring environment, such as 
Microsoft Word, Adobe FrameMaker, or DITA. You do not have to spend time and 
resources learning how to format content for each and every output format in which your 
content will be delivered. You can focus on the content, and then use your Stationery to 
quickly and easily deliver information in the multiple formats that meet the requirements 
for your organization. 

ePublisher reduces wasted time and expenses that occur when multiple groups in your 
organization unknowingly produce the same information at the same time. This publishing 
environment allows your organization to produce content one time. This content can then 
be shared in varying input formats across your organization.

Produce High Quality Deliverables with Fewer Individual Dependencies

Instead of requiring team members to understand the entire process to produce content in 
multiple formats, team members can focus on their areas of expertise. Content developers 
can create informative content to add value to the products and services they document. 
You can also expand the skills of individual team members into important new areas, 
which strengthens your team as a whole.

ePublisher lets you concentrate on producing high-quality content within the authoring 
environment that works for you. You spend much less time on designing, implementing, 
and delivering multiple output formats. With ePublisher, you quickly generate complete, 
ready-to-deploy publications.

ePublisher also allows you to preview, proof, and review your content before you publish 
and deploy it. The comprehensive reports and on-demand reporting help you identify and 
correct any issues that may effect your online content, such as invalid styles, missing 
links, and compliance with Web accessibility standards. In this way, ePublisher ensures 
that the content you produce is of the highest quality and consistency.
Evaluation Guide Chapter 1: Introduction to the WebWorks ePublisher Platform  5



How ePublisher Helps You
Reduce Support Costs and Increase Customer Satisfaction

When you consider the many steps content goes through to get from the content developer 
to its final destination, publishing content can be a tedious, costly process. When an 
organization does not commit its attention and resources to product information, the 
negative results impact many aspects of the business.

Customers want to find their solution by reading as little as possible. Consistent content 
helps customers skim the content and find the information they need. The time content 
developers spend formatting content for various output formats reduces the time they have 
to review and improve the content. Customers can become frustrated when they spend 
time sorting through inconsistent and potentially inaccurate or incomplete information.

Frustrated customers quickly give up and contact customer support, often with a negative 
impression of the company. Increased customer support calls, especially for basic 
concepts and product usage, can waste valuable company resources.

ePublisher provides a workflow designed to make the publishing process as non-intrusive 
as possible. By allowing you to choose your preferred authoring environment and having 
role-focused software components, training time and production costs are reduced. The 
published content is consistent and delivers more value to your customers.

Quickly Update and Deliver Content More Often

If your style or online content requirements change in your organization, you need to make 
changes throughout your content to implement these new requirements. Extended 
production times increase the difficulty and complexity of these changes. ePublisher 
streamlines the production process to enable you to quickly implement and deploy 
updated content. With these streamlined processes in place, you can deliver updated 
content more often.

ePublisher allows you to define and deploy centralized Stationery that all projects use. 
When corporate standards change, such as logos and branding, you can quickly update the 
Stationery to incorporate the new standards. Then, content developers can import the 
updated Stationery into their projects and publish their updated deliverables using the new 
standards without changing or redesigning their source documents.

Reduce Content Management Life Cycle Costs

Due to the limitations of the traditional content model, many organizations want to move 
to a single-sourcing environment. Single sourcing allows the same content to be used 
multiple times and delivered in different formats. Organizations use single sourcing to 
eliminate duplicate content, reduce content translation and maintenance costs, improve 
content consistency, and minimize errors. Single sourcing also allows organizations to 
produce information in various formats using the same source.
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How Organizations Use ePublisher
Many single-sourcing solutions require all content authors to use the same authoring tool. 
ePublisher allows you to develop the content using your preferred content authoring 
environments, such as Microsoft Word, Adobe FrameMaker, or DITA. Each department 
can standardize on the authoring tool that is right for them, and ePublisher ties all the input 
formats together with a single, unified, reliable publishing process. ePublisher allows you 
to create integrated deliverables with source documents from multiple authoring tools.

With ePublisher, you can use your existing authoring tools and content management 
systems to meet organization-wide publishing needs without incurring training or software 
deployment expenses. The open architecture, based on industry-standard XSL, provides a 
flexible solution that you can customize to meet your needs without locking you into a 
proprietary format that could result in expensive future migration costs.

How Organizations Use ePublisher

Companies use ePublisher to meet many of their content development, delivery, and 
maintenance needs:

• Update Web sites automatically with thousands of HTML pages every day

• Merge content across functional boundaries and deliver consistent content on 
corporate intranets and extranets

• Deliver integrated, context-sensitive help systems with products

• Single-source and deliver content in online and print formats

• Deploy content for multiple platforms and devices

The following sections highlight several ways you can use ePublisher to deliver 
consistent, comprehensive information.

Automatically Update Content on Web Sites and Wikis

Corporate Web sites have evolved into far more than just flashy advertising with contact 
information for your business. In addition to attention grabbing marketing about products 
and features, many company Web sites feature tutorials, product demos, specific product 
requirements and details, and Web 2.0 resources such as Wikis and community forums 
where customers can share information.

With ePublisher, you can consistently update the content on your Web site to maintain the 
latest information and make sure it is available to your customers. You can schedule and 
automate content processing and deployment to deliver up to date information each and 
every day.
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How Organizations Use ePublisher
ePublisher also allows you to easily maintain corporate intranets and publish source 
documents from multiple organizations across your company. You can define a standard 
Stationery and templates for teams to use. You can then define an ePublisher job and 
schedule it to search a drop-box folder on a regular basis and publish the content from the 
source documents in that folder using your standard Stationery. This scenario ensures your 
team members have the latest information they need and reduces the expenses associated 
with publishing and maintaining this content on your intranet.

Deliver Full-Featured, Context-Sensitive Help Systems

Products need to provide comprehensive help systems that meet the needs of many 
potential audiences. Content design and delivery must ensure that users get the 
information they need when, where, and how they need it. Some products need to deliver 
different content to different audiences. Other products are sold by multiple companies 
and require distinct product branding.

ePublisher provides comprehensive support for many advanced features used in online 
content design and delivery, including the following elements: 

• Customizable browse navigation and breadcrumbs

• Customizable table of contents and mini-TOCs

• Pop-ups and expandable/collapsible text sections

• Related topics

• Images, image maps, and multiple forms of multimedia

• Context-sensitive help topics

• Merged help systems (multi-volume help)

• Variables and conditions

• Accessibility features, such as alternate text and long descriptions

• Field-level help

Produce Single-Sourced Print and Online Optimized Content

Customers have different needs and expectations for product content. In many cases, 
producing information in multiple formats for users involves extensive conversion and 
customization work to develop and deliver the various formats. Content authors must shift 
their attention to manipulating and converting the content into the many different user 
formats, often for both print and online, instead of focusing their time and efforts on 
developing quality information for users.
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Features Available in Each Output Format
With ePublisher, you can quickly and efficiently produce consistent, effective print and 
online content in multiple formats. ePublisher provides XML/XSL processing and 
intelligent caching to process your source documents faster than ever before.

ePublisher produces the formatting code for you, whether it is HTML, XML, RTF, Wiki 
Markup, or a completely custom format. You do not need to know how to tag files for 
various output formats. With ePublisher, content developers can produce a printable PDF 
manual and a comprehensive online help deliverable immediately after finishing their 
content using the Stationery defined separately from their content.

Features Available in Each Output Format

ePublisher supports many output formats and you can implement many powerful features 
in your online content. Some features are available only in certain output formats. The 
following table summarizes which features are available in each output format.
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Abbreviation alternate text + + + + + +

Acronym alternate text + + + + + +

Bidirectional language 
support

+ + + + + + +

Bullet customization + + + + +

Categories + + +

Citation alternate text + + + + + +

Context-sensitive help using 
topic aliases (topic IDs)

+ + + + + + +

CSS customization + + + + + + + +

Expand/Collapse sections + + + + + +

Favorites + + + + +

File name definition and 
control

+ + + + + + + + + + + + + + + + +

Help window customization + + + +

Image alternate text + + + + + + + + + + + + + +
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Features Available in Each Output Format
Image long description + + + + + + + + + + + + +

Image long description by 
reference

+ + + + + + + + + + + +

Image map alternate text + + + + + + + + + + +

Image scaling by image 
(GraphicScale)

+ + + + + + + + + + + + +

Image style by image 
(GraphicStyle)

+ + + + + + + + + + + + +

Index + + + + + + + + + + + + + + + + + +

Inline comments + +

Meta tag keywords + + + + + + +

Mini (partial) table of contents + + + + + + + + + + + + +

Multimedia links + + + + + + +

Page style customization + + + + + + + + + + + + + + + +

Popup windows + + + +

Related topics + + + + + + + + + + +

Search + + + + + + + + + +

See also links + +

Splash page customization + +

Table alternate text (table 
summary)

+ + + + +

Table of contents + + + + + + + + + + + + + +

Table of contents icon 
customization per topic

+ + + +

Toolbar customization + + + +

What’s This help +
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Evaluation Guide Chapter 2: Planning and
2
Planning and Installing 
ePublisher

This section helps you plan your ePublisher installation and install ePublisher 
components. This section provides information about ePublisher components and 
supported configurations and ePublisher requirements. This section also explains how to 
download and install ePublisher components, use your contract identifier (Contract ID), 
work with license keys, upgrade ePublisher, and troubleshoot installation and licensing 
issues.

Licensing Considerations

Before you can generate output using ePublisher, you must have a valid Contract ID. 
ePublisher uses your Contract ID to automatically handle the licensing of all ePublisher 
components and features. You Contract ID is valid for your ePublisher use. Your contact 
ID may also be valid for other users, as long as the other users were included in the 
contract associated with the contract ID at the time ePublisher was purchased or the other 
users have been added to the same contract.

Currently ePublisher is licensed based on component and input format. ePublisher 
components include ePublisher Express, ePublisher Designer, and ePublisher AutoMap. 
ePublisher input formats include Adobe FrameMaker, Microsoft Word, and DITA-XML. 
Based on the input format of the files you use to author content, you may have access to 
one or more input formats. For more information about each ePublisher component, see 
“WebWorks ePublisher Platform Components” on page 2. For more information about 
Contract IDs, see “Working with Contract IDs” on page 29.

Components and Supported Configurations

Stationery designers must install ePublisher Designer and ePublisher Express on their 
computers. Stationery designers use ePublisher Designer to design Stationery and 
ePublisher Express to test Stationery.
 Installing ePublisher  11



Checklist: Installing ePublisher Components
Writers install ePublisher Express on their computers. Writers use ePublisher Express to 
generate output using Stationery created by a Stationery designer.

If you want to use AutoMap to automate output generation and integrate your output 
generation with content management or version control systems, install ePublisher 
AutoMap and ePublisher Express on the computer where you want to use ePublisher 
AutoMap. ePublisher AutoMap requires ePublisher Express. You can install ePublisher 
AutoMap on its own separate computer, or you can install ePublisher AutoMap on a 
Stationery designer or writer computer where ePublisher Express is already installed. 

The following figure shows a sample ePublisher configuration.

Checklist: Installing ePublisher Components

Use the following checklist to help you install ePublisher components.

Task

1. Verify your computer meets system requirements. For more information, see 
“Requirements” on page 13.

2. Download the ePublisher components you want to install. For more information, see 
“Downloading ePublisher Installation Kits” on page 22.

3. Ensure you have a WebWorks Contract ID obtained from WebWorks staff. For more 
information, see “Obtaining Contract IDs” on page 30.
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Requirements
Requirements

This section lists requirements for ePublisher components and input and output formats.

ePublisher Express, ePublisher Designer, and ePublisher AutoMap 
Requirements

The following table lists the minimum and recommended system requirements for 
ePublisher Express, ePublisher Designer, and ePublisher AutoMap.

Note: Memory requirements can vary with the size of the job, including number of files to 
generate, size of each file, number of images and tables, and more. Generally, 
performance increases with available memory. The following values provide good 
performance for an average job.

4. Verify that the Microsoft .NET 2.0 Framework is installed on each computer where you will 
install ePublisher components. For more information, see “Downloading and Installing the 
Microsoft .NET 2.0 Framework” on page 23.

5. Enable JavaScript in Internet Explorer on each computer where you will install ePublisher 
components. For more information, see “Enabling JavaScript” on page 23.

6. If you have installed previous versions of ePublisher components on your 
computer, uninstall all previous ePublisher versions. For more information, see 
“Uninstalling ePublisher” on page 38.

7. Install ePublisher components.For more information, see “Installing ePublisher” on 
page 23.

Task

Minimum Recommended

Processor Pentium IV or AMD equivalent 
processor

3 GHz or faster Pentium IV or AMD 
equivalent processor

Memory 512 MB RAM 1 GB RAM
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Requirements
Additional Input Format Requirements

Please refer to the following page for up-to-date input requirements: 
http://wiki.webworks.com/Permalinks/InputRequirements

Additional Output Format Requirements

You can use ePublisher to produce output in several different formats. This section 
provides output format requirements for each output format ePublisher supports.

Dynamic HTML

To view Dynamic HTML, users must have a browser that supports HTML 4.0 installed. 
HTML 4.0 was published in late 1997, and the major browsers, such as Internet Explorer, 
Firefox, and Safari support HTML 4.0. For more information about the HTML version a 
browser supports, see the documentation for the browser. If you choose to implement 
online features that require JavaScript, such as popups, users may also need JavaScript 
enabled. Most browsers have JavaScript enabled by default. For more information about 
enabling JavaScript in a browser, see the documentation for the browser.

eBook - ePUB 2.0

To generate output in this format, there are no external tools required. However, you will 
need a compatible ePUB reader in order to view the generated output. For development 
purposes, it is common practice to use an ePUB reader on your computer desktop, for 
example, you can use Adobe Digital Editions available at: 
http://www.adobe.com/products/digitaleditions/Microsoft Windows.

Available Disk 
Space

1 GB available hard disk space 2 GB available hard disk space

Operating System Microsoft XP • Microsoft Windows XP or later

• ePublisher AutoMap has also 
been tested and verified for 
compatibility on Microsoft 
Windows Server 2003 Standard 
Edition and Microsoft Windows 
Server 2003 Enterprise Edition.

Additional 
Software

• Depending on input 
requirements

• Microsoft .NET Framework 2.0 
or later

• Depending on input requirements

• Microsoft .NET Framework 2.0 or 
later

Display 800 x 600 display screen resolution 1280 x 1024 display screen resolution 
(dual monitors supported)

Minimum Recommended
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Requirements
Eclipse Help

To generate Eclipse Help, you must have the Java2 Platform SDK version 1.2.2 or later 
installed. You can download the Java2 Platform SDK for free from the Sun Microsystems 
Web site at http://java.sun.com/javase/index.jsp. 

If you are using ePublisher to generate Eclipse Help, ePublisher includes a viewer that you 
can use on the computer where you installed ePublisher to view the Eclipse Help you 
generated using ePublisher.

To view Eclipse Help when you include Eclipse Help with an application, users must have 
the Eclipse integrated development environment (IDE) installed. Typically, application 
developers configure their applications to install the Eclipse IDE with the Eclipse Help 
content to ensure users can view the Eclipse Help while using the application. To view 
Eclipse Help, users must also have Microsoft Internet Explorer 6.0 or later or a Mozilla-
based browser 1.7 or later installed.

Microsoft HTML Help 1.x

To generate Microsoft HTML Help, you must have Microsoft HTML Help Workshop 1.x 
installed. If you do not have Microsoft HTML Help Workshop installed, ePublisher will 
ask you if you want to install Microsoft HTML Help Workshop during the ePublisher 
installation process. You can also download the Microsoft HTML Help Workshop for free 
from the Microsoft Developer Network Web site at http://msdn.microsoft.com/en-
us/library/ms669985.aspx.

To view Microsoft HTML Help, users must have the Microsoft HTML Help viewer 
installed. The Microsoft HTML Help viewer is installed with most Windows operating 
systems in use today. Users must also have Internet Explorer 4.0 or later installed. 
Microsoft HTML Help does not require that users use Internet Explorer as their default 
browser. Microsoft 

Note: Due to the legacy nature of this help run time, if you are generating your help from 
a networked location, you must map your help drive to a mapped letter such as z:\. 
UNC drives such as \\server.example.com\directory will not work as output 
locations for this help format. For more information on this issue, please refer to 
Microsoft’s Support website and search for your version of Windows.

Microsoft Reader

To view Microsoft Reader files, users must have Microsoft Reader installed. You can 
download Microsoft Reader for free from the Microsoft Web site at 
http://www.microsoft.com/reader/downloads/default.asp.
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Requirements
Microsoft WinHelp

To view Microsoft WinHelp files, users must have the Windows Help viewer 
(winhlp32.exe) installed. The Windows Help viewer has been included with Microsoft 
Windows versions starting with the Microsoft Windows 3.1 operating system. However, 
beginning with the release of Windows Vista, the Windows Help viewer no longer ships as 
a feature of Windows. Users who want to view Microsoft WinHelp on computers running 
Windows Vista must download and install the Windows Help viewer from the Microsoft 
Download Center at http://www.microsoft.com/downloads/search.aspx?displaylang=en.

Oracle Help

To generate Oracle Help, you must have the Java2 Platform SDK version 1.2.2 or later 
installed on your computer. You can download the Java2 Platform SDK for free from the 
Sun Microsystems Web site at http://java.sun.com/javase/index.jsp. The Java 2 Platform is 
also known as the Java Platform, Standard Edition (Java SE).

To view Oracle Help, users must have the Java Runtime Environment (JRE) installed on 
their computer. Typically application developers configure their applications to install the 
JRE with the Oracle Help content to ensure users can view the Oracle Help while using the 
application. Oracle Help components must be installed and viewed on the local computer.

Palm Reader

To generate Palm Reader files, you must have DropBook installed. DropBook is a Palm 
Reader utility that ePublisher uses to convert generated output into a single .pdb file 
required by Palm Reader software. You can download the DropBook utility for free from 
the eBook Reader Web site at 
http://www.ereader.com/ereader/software/product/15099_dropbook_win.htm.

To view Palm Reader files, users must have eReader software installed. You can download 
the eReader software on the eBook Reader Web site at 
http://www.ereader.com/ereader/software/browse.htm.

PDF

To view PDF files, users must have Adobe Reader installed. You can download Adobe 
Reader for free from the Adobe Web Site at 
http://www.adobe.com/products/acrobat/readstep2_allversions.html.

Customers may encounter issues with font embedding and Windows 7. Please refer to the 
following resources to address this issue:

http://wiki.webworks.com/Permalinks/Solutions/Output/PDF/ProblemsInWindows7  
http://wiki.webworks.com/Permalinks/Solutions/Output/PDF/IssuesWithTrueTypeFonts
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Requirements
PDF -XSL-FO

To generate PDF - XSL-FO files, you must have the Java2 Platform SDK version 1.2.2 or 
later installed. You can download the Java2 Platform SDK for free from the Sun 
Microsystems Web site at http://java.sun.com/javase/index.jsp.

Simple HTML

To view simple HTML, users must have a browser that supports HTML 3.2 or later. 
HTML 3.2 was published in early 1997, and the major browsers, such as Internet 
Explorer, Firefox, and Safari support HTML 3.2. For more information about the HTML 
version a browser supports, see the documentation for the browser. 

Sun JavaHelp 1.1.2 and 2.0

To generate Sun JavaHelp 1.1.2 or 2.0, you must have the Java2 Platform SDK 
version 1.2.2 or later installed on your computer. You can download the Java2 Platform 
SDK for free from the Sun Microsystems Web site at http://java.sun.com/javase/index.jsp. 
The Java 2 Platform is also known as the Java Platform, Standard Edition (Java SE).

To view Sun JavaHelp, users must have the Java Runtime Environment (JRE) installed on 
their computer. Typically, application developers configure their applications to install the 
JRE with the Sun JavaHelp content to ensure users can view the Sun JavaHelp while using 
the application. Sun JavaHelp components must be installed and viewed on the local 
computer.

WebWorks Help 5.0

To view WebWorks Help, users must have JavaScript enabled in the browser. If JavaScript 
is not enabled, then the help system does not display in its entirety. For more information 
about determining whether JavaScript is enabled in your browser, see your browser 
options. For more information about enabling JavaScript in Internet Explorer, refer to 
“Enabling JavaScript” on page 23.

WebWorks Help has been tested on the following platforms:

• Internet Explorer

• Mozilla Firefox

• Netscape

• Safari

• Google Chrome

• Opera
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Requirements
Please refer to the WebWorks wiki for an up-to-date list of supported browsers: 
http://wiki.webworks.com/Permalinks/BrowserSupport

WebWorks Reverb

WebWorks Reverb can now be viewed directly from your computer’s file system or from a 
running web server. This means that you can use this format to deliver online help as part 
of a non-networked help system. However, in order to provide Reverb’s social-media 
capabilities (i.e. commenting, likes) to your end-users you must deploy the output to a 
system that is running a web server. Then your end-users must access the content via an 
http or https url. If you do not have a web server, you can configure IIS on Windows or 
any other available web server software. For more information on IIS, consult the 
following resource.

When you are using ePublisher to generate WebWorks Reverb, ePublisher includes a 
viewer that you can use on the computer where you installed ePublisher to view the 
WebWorks Reverb output you generated using ePublisher.

WebWorks Reverb has been designed to perform gracefully on most any browser and 
browsing device. In cases where the screen resolution of the viewing device is not wide 
enough, the table of contents will not automatically display on the left-hand side of the 
screen. In this scenario, users will have to select the table of contents toolbar icon in order 
to display the table of contents, this is by design and allows your users to acheive 
maximum functionality no matter what device they may be using.

In rare cases where users have javascript disabled on their browser, the content will still be 
displayed, however the layout may be sub-optimaland all navigation icons will not be 
displayed.

WebWorks Reverb has been tested on the following platforms:

• Internet Explorer

• Mozilla Firefox

• Safari

• Google Chrome

Please refer to the WebWorks wiki for an up-to-date list of supported browsers: 
http://wiki.webworks.com/Permalinks/BrowserSupport

Wiki - Confluence

To view Confluence Wiki output, you must deploy the output to a server computer where 
Confluence 2.10.2or later is installed. You may find it helpful to set up a staging 
Confluence server computer if you generate Confluence output. A staging Confluence 
computer allows you to view your generated Wiki output before deploying your generated 
Wiki output to a production Confluence computer.
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Requirements
Before you deploy Confluence output, ensure the following APIs and plug-ins are 
installed on the Confluence Wiki:

• Confluence Remote API

This API is enabled by default when Confluence is installed. The Confluence 
Remote API works in conjunction with the Confluence XML RPC API.

• Confluence XML RPC API

This API should be enabled, and this API works in conjunction with the Confluence 
Remote API.

• Adaptivist Content Formatting Macros plug-in

The Adaptivist Content Formatting Macros plug-in is available at 
http://confluence.atlassian.com/display/CONFEXT/Content+Formatting+Macros. 
ePublisher uses this plug-in to control indents and any kind of complex table 
formatting such as row and column spans. This plug-in also provides support for 
.css classes.

• Ensure that the Confluence Compatibility Macros are disabled. The Confluence 
Compatibility Macros define tables. If the Confluence Compatibility Macros and 
the Adaptivist Content Formatting Macros are enabled at the same time, table 
macro definition conflicts may result.

• The Confluence WYSIWYG editor does not preserve escaped characters if those 
character escapes are specified as HTML entities, such as &#46;. 

Note: Escape characters indicate that a character sequence is not formatting 
instructions for the Wiki. For example, on some Wikis, and asterisk (*) 
character followed by a space at the beginning of a line indicates a bullet. 
When the Wiki reads this markup, it converts the asterisk character and the 
space into a bullet. However, if you need to have an asterisk character 
followed by a space at the beginning of a line on your Wiki page, and not a 
bullet, you can use an escape character, such as '\'to display the content 
correctly.

When ePublisher generates output for Wikis, it automatically and appropriately 
escapes characters in your source documents so your content displays correctly in 
the generated output. However, if you deploy content with escape characters to a 
Confluence Wiki server and users then edit the content using the Confluence 
WYSIWYG editor, the WYSIWYG editor removes any escape characters used on 
the page to display content. To avoid this issue, disable the Confluence WYSIWYG 
editor on the Wiki server where you deploy your Confluence Wiki output.

• When you deploy content to a Confluence Wiki, pages are deployed based on the 
table of contents hierarchy. You can see this hierarchy in the Confluence Browse 
view.
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Requirements
For more information about Confluence, including installing and configuring Confluence, 
see the Confluence web site at www.atlassian.com/software/confluence. For more 
information about deploying Confluence Wiki output using ePublisher, see the ePublisher 
Writer Guide. 

Wiki - MediaWiki

To view MediaWiki output, you must deploy the output to a computer where 
MediaWiki 1.11 or later is installed. You may find it helpful to set up a staging MediaWiki 
server computer if you generate MediaWiki output. A staging MediaWiki computer allows 
you to view your generated Wiki output before deploying your generated Wiki output to a 
production MediaWiki computer.

Before you deploy MediaWiki output, review the following settings on the MediaWiki:

• The user account you specify for ePublisher to use when deploying output to a 
MediaWiki requires Write access to the Wiki and the ability to remotely push 
content to the Wiki.

• ePublisher uses the MediaWiki Write API when deploying output to MediaWiki. 
Using the MediaWiki Write API ensures that any surge protection limits configured 
on the Wiki do not block ePublisher from deploying output to the Wiki. Ensure that 
the MediaWiki Write API is enabled before deploying output to MediaWiki. The 
Write API is disabled by default on MediaWiki.

• If you try to use ePublisher to deploy large page files, such as 2 MB or 3 MB page 
files, to your MediaWiki server, MediaWiki will display the following error if you 
do not have enough PHP memory allocated in MediaWiki:

Fatal error: Allowed memory size of nnnnnnn bytes exhausted (tried to 
allocate nnnnnnnn bytes)

Ensure you have enough PHP memory allocated in MediaWiki if you plan to use 
ePublisher to deploy large page files to your MediaWiki server. You can raise the 
PHP memory limit in the php.ini and LocalSettings.php files. For more 
information, see http://www.mediawiki.org/wiki/Manual:Errors_and_Symptoms.

For more information about MediaWiki, including installing and configuring MediaWiki, 
see the MediaWiki Web site at www.mediawiki.org. For more information about 
deploying MediaWiki output using ePublisher, see the ePublisher Writer Guide. 

Wiki - MoinMoin

To view MoinMoin Wiki output, you must deploy the output to a computer where 
MoinMoin 1.6.4 or later is installed. You may find it helpful to set up a staging MoinMoin 
server computer if you generate MoinMoin output. A staging MoinMoin computer allows 
you to view your generated Wiki output before deploying your generated Wiki output to a 
production MoinMoin computer. 
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Requirements
Before you deploy MoinMoin Wiki output, review the following settings on the 
MoinMoin Wiki:

• The user account you specify for ePublisher to use when deploying output to a 
MoinMoin Wiki requires Write access to the Wiki and the ability to remotely push 
content to the Wiki. Ensure the user account ePublisher uses when deploying 
content to the Wiki has the appropriate Write permissions on the Wiki.

• Ensure xmlrpc actions are enabled on the MoinMoin Wiki.

Note: MoinMoin does not support the XML-RPC protocol when run as a CGI application.

• Based on the MIME type assigned to the files you include in your generated output, 
you may need to add content types to the mimetypes_embed setting in the 
wikiconfig file on the MoinMoin Wiki. For example, if you use Scalable Vector 
Graphics (.svg) files when generating MoinMoin Wiki output, ensure that you add 
image/svg+xml to the mimetypes_embed setting.

• You can configure surge protection limits for requests on a MoinMoin Wiki, 
including the type of Write requests ePublisher can make when deploying output to 
the Wiki. Ensure you understand how surge protection is configured on the 
MoinMoin Wiki before you use ePublisher to deploy content to a MoinMoin Wiki.

Surge protection limits are typically configured to help protect the performance of 
the Wiki and to ensure the Wiki is available and has appropriate content for its 
intended users. Surge protection settings protect the Wiki from malicious users, 
including spammers, who may want to try and push spam or other unwanted 
content onto Wikis. In MoinMoin, you configure surge protection limits in the 
wikiconfig file. Verify that ePublisher can deploy content to a MoinMoin Wiki 
using the surge protection limits configured for the MoinMoin Wiki.

For more information about MoinMoin, including installing and configuring MoinMoin, 
see the MoinMoin Web site at http://moinmo.in/. For more information about deploying 
MoinMoin Wiki output using ePublisher, see the ePublisher Writer Guide. 
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Downloading ePublisher Installation Kits

ePublisher installation kits are available for download as .zip files on a secure area on the 
WebWorks Web site. You can obtain ePublisher installation kits through one of the 
following methods:

• If you are evaluating ePublisher, the WebWorks customer service team will send 
you an email that contains a link to the location where you can download the 
ePublisher installation kit.

• If you are a new ePublisher customer, the WebWorks customer service team will 
send you an email that contains a link to the location where you can download the 
ePublisher installation kit when you purchase ePublisher.

• If you are an existing ePublisher customer with an active maintenance 
agreement, the WebWorks customer service team will automatically send you an 
email that contains a link to the location where you can download the ePublisher 
installation kit each time a new version of ePublisher releases. If you have a My 
Cases login for the WebWorks technical support Web site, you can also obtain the 
ePublisher installation kit in the My Cases area when you log in to the WebWorks 
technical support site.

• If you are an existing ePublisher customer without an active maintenance 
agreement, contact the WebWorks account management team for more 
information.

The link you receive to the download location for the ePublisher installation kit is 
typically active for only one to two weeks. ePublisher installation kit download locations 
are changed often for security reasons. If you need the latest link to an ePublisher 
download kit, you can request a link by submitting a support request on the WebWorks 
Web site at http://www.webworks.com/Support/. WebWorks technical support will verify 
that you purchased an ePublisher license for the requested component and then provide a 
link where you can download the requested installation kit.

To download an ePublisher installation kit

1. Click the download link in the email from WebWorks.

2. On the WebWorks download page, click the link for the ePublisher component you 
want to install.

3. Click Save.

4. Browse to a location on your local computer where you want to save the installation 
kit, and then click Save.

5. Click Close when the download completes.

6. Browse to the location on your local computer where you saved the .zip file for the 
ePublisher component.
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7. Extract the contents of the .zip file to a folder on your local computer.

Note: Each installation kit contains a setup.exe file and an .msi file. Ensure you 
extract the setup.exe file and the .msi file for the ePublisher component 
into the same folder when you extract the contents of the .zip file. The 
setup.exe file registers the setup program as needed with the operating 
system and then runs the .msi file.

Downloading and Installing the Microsoft .NET 2.0 
Framework

ePublisher components require the Microsoft .NET 2.0 Framework. To see if the 
Microsoft .NET 2.0 Framework is already installed on your computer, in Control Panel, 
open Add or Remove Programs and see if the Microsoft .NET 2.0 Framework is listed. 

If you do not have the Microsoft .NET 2.0 Framework installed, you can download the 
Framework for free from the Microsoft .NET Framework Developer Center at 
http://msdn.microsoft.com/netframework/downloads.

After you download the latest version for the Microsoft .NET 2.0 Framework, install the 
framework on each computer where you will install ePublisher components. Follow the 
instructions provided in the Microsoft .NET 2.0 Framework installation kit to install the 
framework.

Enabling JavaScript

To use ePublisher, you must enable JavaScript in Microsoft Internet Explorer.

To enable JavaScript in Internet Explorer

1. Open Microsoft Internet Explorer.

2. On the Tools menu, click Internet Options.

3. On the Security tab, click Custom Level.

4. Under Active Scripting, click Enable.

Installing ePublisher

This section explains how to install ePublisher components. Read this section before you 
install ePublisher components.
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Installation Order for ePublisher Components

Ensure you install ePublisher components in the correct order. Review the following 
installation options before you install ePublisher components:

• If you want to generate output using Stationery created by a Stationery designer, 
install only ePublisher Express on the computer.

• If you want to design Stationery and generate output, install ePublisher Express 
and ePublisher Designer on the computer. 

Note: ePublisher Designer requires ePublisher Express. Ensure you install 
ePublisher Express on the computer before you install ePublisher Designer.

• If you want to schedule and automate output generation, install ePublisher 
Express and ePublisher AutoMap on the computer where you want to use 
ePublisher AutoMap.

ePublisher AutoMap requires ePublisher Express. Ensure you install ePublisher 
Express on the computer before you install ePublisher AutoMap. You can install 
ePublisher AutoMap using one of the following configurations:

– On its own separate computer where ePublisher Express is already installed

– On a Stationery design computer where ePublisher Express and ePublisher 
Designer are already installed

– On a writer computer where ePublisher Express is already installed

Installing ePublisher Components

This section provides instructions for installing ePublisher components, including 
ePublisher Express, ePublisher Designer, and ePublisher AutoMap.

Note: You must install ePublisher Express first. Then, you can install ePublisher Designer 
and ePublisher AutoMap. Both ePublisher Designer and ePublisher AutoMap 
require ePublisher Express.

If you are upgrading from a previous version of ePublisher, review the upgrade 
instructions. For more information, see “Upgrading from Previous Versions” on page 32.

To install ePublisher components

1. Log on as a user using a user account that is a member of the Administrators group 
on the local computer.

2. Close all instances of Microsoft Office applications running on the local computer, 
including instances of Microsoft Word and Microsoft Outlook. Close all instances 
of Adobe FrameMaker running on the computer.
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3. Run the setup.exe file in the installation package for the ePublisher component 
you want to install.

4. Review the welcome message, and then click Next.

5. Review the license agreement. If you agree to the terms of the agreement, click I 
Agree, and then click Next.

6. Select the application shortcuts you want to create, and then click Next.

7. If you are installing ePublisher Express, specify whether you want to allow 
ePublisher Express users to modify target settings, condition settings, variable 
values, and cross-reference definitions, and then click Next.

Note: If you are evaluating ePublisher Express, ensure you select this check box. 
You will modify target settings as you explore ePublisher during your 
evaluation. For more information, see “Customizing Exploring ePublisher 
Output” on page 74.

• If you select this check box, ePublisher Express users can modify target 
settings, condition settings, variable values, and cross-reference definitions 
used to generate output. This option gives users more control over their 
ePublisher output, but users can produce output that differs from the 
standards defined in Stationery.

• If you do not select this check box, ePublisher Express users cannot modify 
target settings, condition settings, variable values, and cross-reference 
definitions. Projects use the target settings, condition settings, variable 
values, and cross-reference definitions defined in the Stationery. 

You can enable permissions to modify target settings, conditions settings, variable 
values, and cross-definitions later if needed. For more information, see “Enabling 
Target Setting Permissions After Installing ePublisher Express” on page 28. 

8. Specify the location of the installation directory, and then click Next. The default 
installation directory is C:\Program Files\WebWorks.

9. Click Next to confirm your selections and to begin installing the ePublisher 
component.
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10. In the WebWorks Licensing Info window, complete the following steps:

a. Enter your Contract ID. If you previously installed ePublisher on the 
computer using a valid Contract ID, ePublisher will automatically detect the 
Contract ID and display your Contract ID information. For more information 
about contract IDs and obtaining a Contract ID, see “Working with Contract 
IDs” on page 29 “Obtaining Contract IDs” on page 30.

b. Enter your email address. If you have an email address that you use as your 
WebWorks support login, enter that email address.

c. Enter the name of your computer.

d. Click Confirm.

11. If the installer displays the HTML Help Workshop 1.3 Setup window, you can 
install Microsoft HTML Help Workshop 1.3 as part of your ePublisher installation. 
Install Microsoft HTML Help Workshop if you plan to generate Microsoft HTML 
Help output.

• If you want to install Microsoft HTML Help Workshop 1.3, click Yes, and 
then follow the instructions to install Microsoft HTML Help Workshop.

• If you do not want to install Microsoft HTML Help Workshop 1.3, click No. 

12. Click Close when the installation completes. ePublisher also opens a new browser 
window and displays a page on the www.webworks.com web site when the 
installation completes.

13. Restart your computer to update and register all configuration files.
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14. If you installed ePublisher on Windows Vista and you plan to use ePublisher with 
Adobe FrameMaker, due to an issue with the FrameMaker Developers Kit (FDK), 
after you install ePublisher you must run ePublisher Express as an Administrator at 
least once.

When you run ePublisher Express as an Administrator, you must open or scan an 
Adobe FrameMaker source document within ePublisher to register the FDK with 
Windows Vista as a trusted application. 

Run as an Administrator and register the FDK by completing the following steps:

a. If you specified that you wanted ePublisher to create a desktop shortcut 
when you installed ePublisher, on your desktop, right-click the ePublisher 
shortcut.

b. If you did not specify that you wanted ePublisher to create a desktop 
shortcut when you installed ePublisher, browse to the following location, 
and then right-click the appropriate .exe file

– Program Files\WebWorks\ePublisher\2013.3\ePublisher 
Express\WebWorks.ePublisherExpress.exe

– Program Files\WebWorks\ePublisher\2013.3\ePublisher 
Designer\WebWorks.ePublisherDesigner.exe

c. Click Run as administrator.

d. Click Allow to confirm that you trust the application. The ePublisher 
component you selected opens.

e. Open an existing project that contains an Adobe FrameMaker source 
document or create a new project that contains an Adobe FrameMaker source 
document.

f. In Document Manager, select an Adobe FrameMaker source document.

g. On the Project menu, click Scan Selected to register the FDK with Windows 
Vista.

Understanding Installed Sample Projects and Stationery

ePublisher Express and ePublisher Designer install sample projects and Stationery. You 
can use these sample projects and Stationery to see some examples of how you can use 
ePublisher to generate output. For more information about using these sample projects and 
Stationery to generate output, see “Exploring ePublisher Using Sample Source 
Documents, Projects, and Stationery” on page 60. 
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Enabling Target Setting Permissions After Installing ePublisher Express

You can customize target settings in a project only if you have target setting modification 
permissions. If you are using ePublisher Designer, you have target setting modification 
permissions. If you are using ePublisher Express, you may or may not have target setting 
modification permissions. When you install ePublisher Express, you must select the Allow 
users to modify Target Settings and Properties check box in order to have target setting 
modification permissions, including permissions to modify the target settings for the 
targets available in your project. If you do not select this check box during installation, 
you will not be able to customize target settings in projects. This check box is not selected 
by default as part of an ePublisher Express installation.

If you did not select the Allow users to modify Target Settings and Properties check box 
when you installed ePublisher Express, only the Merge Settings and Deploy menu 
options display on the ePublisher Express Target menu.

If you selected the Allow users to modify Target Settings and Properties check box when 
you installed ePublisher Express, the Conditions, Variables, Cross Reference Rules, 
Merge Settings, Target Settings, and Deploy menu options all display on the ePublisher 
Express Target menu.

If you need to enable target setting permissions once ePublisher Express has been 
installed, you can enable target setting permissions in ePublisher Express by modifying an 
ePublisher Express configuration file. Ensure you consult with your Stationery designer to 
verify that it is appropriate for you to enable target setting permissions in ePublisher 
Express before you enable target setting permissions.

To enable target setting permissions after installing ePublisher Express

1. Close the ePublisher Express user interface.

2. Browse to the location of the WebWorks.ePublisherExpress.exe.config file. By 
default, ePublisher installs this file in the following location when you install 
ePublisher Express:

Program Files\WebWorks\ePublisher 
Express\WebWorks.ePublisherExpress.exe.config

3. Open the WebWorks.ePublisherExpress.exe.config file in Notepad.

4. Change the value of the AllowModifications key to true. The 
AllowModifications key entry should be similar to the entry below:

<add key="AllowModifications" value="true" />

5. On the File menu, click Save, and then close Notepad.

6. Open ePublisher Express and verify on the Target menu that the Conditions, 
Variables, Cross Reference Rules, and Target Settings menu options display. 
28  Chapter 2: Planning and Installing ePublisher Evaluation Guide



Working with Contract IDs
For more information about installing ePublisher Express with target setting permissions, 
see “Installing ePublisher Components” on page 24.

Working with Contract IDs

ePublisher no longer requires you to manually enter license keys. ePublisher now uses 
Contract IDs to enable product functionality, which simplifies the ePublisher licensing 
process.

A Contract ID is a unique identifier that identifies the number of users and type of 
functionality enabled for your ePublisher installation. WebWorks generates an appropriate 
Contract ID for your ePublisher installation when you purchase ePublisher or request an 
evaluation copy of ePublisher. A Contract ID enables functionality based on the items and 
time frame specified in the purchase contract between your company and WebWorks.

If you have a valid contract ID for one version of the ePublisher product, when a new 
version of ePublisher releases, you can continue to use your same Contract ID when you 
upgrade to the new version of the product. You can also continue to use your same 
Contract ID if you have to uninstall and then re-install a version of ePublisher.

ePublisher licensing is flexible, and the WebWorks team can work with you ensure that 
you have the licensing that is right for you. Contact WebWorks Sales at 
sales@webworks.com or WebWorks Customer Service at 
customerservice@webworks.com to discuss any special licensing needs you may have.

Viewing Licensing and Contract ID Information

You can view licensing information in the License Information window in ePublisher. 
ePublisher uses adapter license keys, or activation codes, to enable ePublisher 
functionality. Adapter licensing information is specified in your Contract ID. ePublisher 
uses an Internet connection to connect to the ePublisher licensing server and periodically 
retrieve and update adapter activation codes as needed based on your Contract ID.

Note: If you need to install ePublisher in an environment without Internet connectivity, 
WebWorks can provide Contract IDs that support this environment. For more 
information, see “Managing Licensing in Environments without Internet 
Connectivity” on page 31.

ePublisher licenses, or activation codes, do not display in the ePublisher user interface, but 
you can view the adapters for which you are licensed and your Contract ID number in the 
ePublisher user interface.
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To view ePublisher licensing and Contract ID information

1. On the Help menu, click License Keys. ePublisher displays the input formats for 
which the component is licensed in the License Information window.

2. If you want to view your Contract ID number, click Info.

Obtaining Contract IDs

ePublisher now uses Contract IDs instead of license keys to enable ePublisher 
functionality.

If you are evaluating ePublisher, the WebWorks customer service team will send you an 
email that contains a Contract ID you can use when you install an evaluation copy of 
ePublisher. If you have not received an evaluation Contract ID or are having problems 
with your evaluation license, send an email to customerservice@webworks.com.

If you are a new ePublisher customer, the WebWorks customer service team will send 
you an email that contains your Contract ID when you purchase ePublisher. If you have 
not received a Contract ID or are having problems with your licensing, send an email to 
customerservice@webworks.com.

If you are an existing ePublisher customer with an active maintenance agreement, the 
WebWorks customer service team will automatically send you an email that contains a 
link to the location where you can download the ePublisher installation kit. ePublisher will 
automatically detect and use your existing Contract ID each time you install a new version 
of the ePublisher product. If you have not received a Contract ID or are having problems 
with licensing, send an email to customerservice@webworks.com or submit a support 
request.

If you are an existing ePublisher customer without an active maintenance agreement, 
contact the WebWorks account management team for more information about obtaining 
your Contract ID by sending an email to sales@webworks.com.

For more information about Contract IDs, see “Working with Contract IDs” on page 29 
and “Entering Contract IDs” on page 30.

Entering Contract IDs

ePublisher now uses Contract IDs instead of license keys to enable ePublisher 
functionality. You must enter your Contract ID, email address, and computer name before 
you can use ePublisher components. The Contract ID enables the ePublisher product 
components and ePublisher input formats for which you are licensed. For more 
information about Contract IDs, see “Working with Contract IDs” on page 29.
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To enter a Contract ID

1. On the Help menu, click License Keys. ePublisher displays the input formats for 
which the component is licensed in the License Information window.

2. Click Update.

3. In the Contract field, enter your Contract ID.

4. In the Email field, enter your email address. If you have an email address that you 
use as your WebWorks support login, enter that email address.

5. In the Computer field, enter the name of the computer where you are installing 
ePublisher.

6. Click Confirm.

Managing Licensing in Environments without Internet Connectivity

ePublisher uses an Internet connection to connect to the ePublisher licensing server and 
retrieve or update adapter activation codes as needed based on your Contract ID. If you 
need to install ePublisher in a restricted environment where ePublisher computers do not 
have Internet access, contact WebWorks Sales at sales@webworks.com or WebWorks 
Customer Service at customerservice@webworks.com to request a non-network Contract 
ID. The ePublisher licensing model is flexible, and WebWorks can work with you to 
provide non-network Contract IDs or other licensing solutions appropriate for your 
environment.

Updating Licensing

ePublisher automatically contacts the ePublisher licensing server as needed to obtain 
updated activation codes. ePublisher communicates with the ePublisher licensing server 
using an Internet connection. ePublisher obtains updated activation codes as appropriate 
based on the licensing specified in your Contract ID.

Note: If your ePublisher is installed in an environment without Internet connectivity, 
WebWorks can provide Contract IDs that support this environment. For more 
information, see “Managing Licensing in Environments without Internet 
Connectivity” on page 31

Typically, you will not need to request updated activation codes, as ePublisher obtains 
updated codes for your automatically. However, you can manually request updated 
activations codes in the ePublisher interface. For example, you may want to manually 
request updated activation codes if you know that the computer where you installed 
ePublisher will not have Internet access for a long period of time. When you request 
updated activations codes in the ePublisher interface, ePublisher immediately establishes 
an Internet connection to the ePublisher licensing server and automatically obtains 
updated activation codes for the ePublisher adapters for which you are licensed.
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To update ePublisher licensing

1. On the Help menu, click License Keys. ePublisher displays the input formats for 
which the component is licensed in the License Information window.

2. Click Update. ePublisher retrieves updated activation codes from the ePublisher 
licensing server.

Deactivating Licensing

You can deactivate ePublisher licensing in the ePublisher user interface. Deactivating 
licensing for the current ePublisher installation allows you to install ePublisher on a 
different computer without affecting the number of available seats allowed by your 
contract.

Note: The terms of the ePublisher end-user license agreement (EULA) allow you to install 
ePublisher Express or ePublisher Designer on one office computer and on one home 
or travelling computer for each assigned ePublisher user seat. ePublisher AutoMap 
licensing terms can vary based on whether ePublisher AutoMap was purchased on a 
per writer or per server basis, or in conjunction with a Content Management System 
(CMS).

To deactivate ePublisher licensing:

1. On the Help menu, click License Keys.

2. Click Unregister.

Upgrading from Previous Versions

In most cases, upgrading from a previous version to a new version of ePublisher can be 
accomplished in just a few steps. This section explains how to prepare for an upgrade, how 
to upgrade a typical ePublisher installation, and how to upgrade an ePublisher 
implementation with advanced customizations.
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Preparing to Upgrade

As you prepare to upgrade your ePublisher installation, ensure you perform the following 
steps:

• Save your Stationery, Stationery design projects, and any projects you currently use 
to generate output to a secure location. Stationery defines the appearance and 
functionality of all the output formats you need. Stationery design projects are the 
ePublisher Designer projects used to create Stationery. For more information about 
Stationery and Stationery design projects, see the ePublisher Design Guide. 

• If you implemented overrides when designing Stationery, ensure you save the files 
in the Formats folder, any override files currently in use, and a copy of the original 
files from which the overrides were created to the secure location. Examples of 
overrides include the following items:

– Modifications to the Page.asp file

– Custom .css files

– Modifications to image files

– Any advanced overrides such as modifications to .xsl or .fti files or files 
in the Formats folder.

When the Stationery designer creates and saves Stationery, ePublisher creates the 
following folders:

• StationeryName\Formats\OutputFormat

• StationeryName\Formats\OutputFormat.base

where StationeryName is the name the Stationery designer specified for the Stationery, 
and OutputFormat is the type of output format the Stationery Designer specified for a 
target in the Stationery. 

The StationeryName\Formats\OutputFormat folder contains any customizations or 
overrides the Stationery designer specified when designing the Stationery. ePublisher 
Express synchronizes with the files in the OutputFormat folder and uses the information 
about customizations and overrides contained in files in the OutputFormat folder to 
generate output.

Note: The Stationery may have one or more OutputFormat folders, based on the settings 
the Stationery designer specified.

The StationeryName\Formats\OutputFormat.base folder contains copies of all the files 
located in the \Program 
Files\WebWorks\ePublisher\release_number\Formats\OutputFormat folder. These 
files define the default output format and transforms and are installed by default when you 
install ePublisher.
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Stationery designers can do a compare, or diff, between the files located in these folders to 
quickly see any customizations or overrides specified for the Stationery. Stationery 
designers can use this information to help them reapply customizations and overrides as 
needed when designing a newer version of the Stationery in ePublisher Designer.

For more information about overrides, see the ePublisher Design Guide.
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Upgrading Typical ePublisher Implementations

After you save your existing Stationery design projects, Stationery, any projects you 
currently use to generate output, and any copies of override files to a secure location, 
perform the following steps:

• On the Stationery designer computer, uninstall all existing versions of ePublisher 
components, such as ePublisher Express, ePublisher Designer, and ePublisher 
AutoMap. The Stationery design computer is the computer the Stationery 
designer uses to create and update Stationery. ePublisher Express and ePublisher 
Designer are installed on the Stationery design computer. Based on your 
configuration, ePublisher AutoMap may also be installed on the Stationery design 
computer.

• Install the new version of ePublisher Express and ePublisher Designer on the 
Stationery designer computer. Also install the new version of ePublisher AutoMap 
if you run ePublisher AutoMap on the Stationery designer computer.

• Open your existing Stationery design projects using the new version of ePublisher 
Designer.

• Generate output and verify that your output generates as expected. Make any 
adjustments as needed. 

– If you have implemented typical overrides in a Stationery design project, 
such as overrides to Page.asp files, custom .css files, or image files, you 
can continue to use your overrides to these files, and the new version of 
ePublisher will recognize and use these existing modifications when 
generating output.

– If you have implemented advanced overrides, such as overrides to .xsl or 
.fti files, or overrides to files in the Formats folder, update these files in 
your new ePublisher installation to include your advanced overrides. For 
more information, see “Upgrading Implementations with Advanced 
Customizations” on page 36.

Note: When ePublisher Designer detects overrides, by default it will not 
update to the latest version of the format. This means that no 
modifications will be necessary in order to continue using your 
Stationery. However, in this default mode, you will not get any of the 
format improvements built into the latest release. If you want these 
improvements, then you will have to configure the Project Settings to 
use the latest version of ePublisher’s formats.

• Create new Stationery for each Stationery design project.

• Deploy the updated Stationery to an appropriate location.

• On each writer computer, uninstall ePublisher Express and then reinstall the new 
version of ePublisher Express.
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• The next time writers generate output, they open their existing projects using the 
new version of ePublisher Express. Writers can choose to synchronize their projects 
immediately to obtain the latest Stationery and then generate output, or writers can 
continue using their existing Stationery until they are ready to move to the latest 
version of the Stationery.

Upgrading Implementations with Advanced Customizations

If you have implemented advanced overrides in the Stationery design, such as overrides to 
.xsl or.fti files, or overrides to files in the Formats folder, ensure you save a copy of the 
following items to a secure location before uninstalling a previous version of ePublisher 
and installing a new version:

• Overrides currently used in the Stationery design project

• A copy of the original files from which the overrides were created

If you want to continue to use your advanced customizations with the new version of 
ePublisher, first uninstall your previous ePublisher version and then install a new 
ePublisher version. Then identify and include your overrides in the new versions of the 
ePublisher files as appropriate by performing a three-way merge of the following items:

• A copy of the existing override file used in the Stationery design project, located in 
the StationeryName\Formats\OutputFormat folder, where StationeryName is 
the name the Stationery designer specified for the Stationery, and OutputFormat is 
the type of output format the Stationery Designer specified for a target in the 
Stationery.

• A copy of the original file from which the override was created, available in the 
tationeryName\Formats\OutputFormat.base folder, where StationeryName is 
the name the Stationery designer specified for the Stationery, and OutputFormat is 
the type of output format the Stationery Designer specified for a target in the 
Stationery.

• A copy of the new file from the new version of ePublisher

Performing a three-way merge allows you to identify the code you changed when you 
created the override, and also allows you to quickly and easily create the override again in 
the new ePublisher files. You may find tools such as Araxis Merge Pro, available at 
http://www.araxix.com/merge, or KDiff3, available at http://kdiff3.sourceforge.net, 
helpful as you compare and merge override files.

After you perform your three-way merge and update the files you want to override in the 
new version of ePublisher with the overrides you specified in the previous version, test 
your overrides by generating output using the new version of ePublisher Designer and the 
Stationery design project to confirm your output generates appropriately. After you verify 
the output generated correctly using your advanced customizations, you can create new 
Stationery using the Stationery design project and then deploy the updated Stationery that 
includes your advanced customizations to writers to use to generate output.
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Upgrading from Previous Versions
Upgrading Advanced Customizations of WebWorks Reverb Skin

The WebWorks Reverb output format is highly customizable and chances are you may 
have made advanced customizations to this format. If you are upgrading from a prior 
release, then you will want to understand what files are most likely to be customized and 
how this is affected when you change the Skin Target Setting.

If you have or plan to customize any of the WebWorks Reverb skins, then most likely you 
will have to modify one or more of the following files.

When working with alternate skins, you need to be aware of which files are most likely 
affected as a result of changing the skin type. If you have Advanced Customizations in any 
of these files, then you need to re-examine the diffs of these files after you switch the skin 
type. Most likely you will see significant changes. Here are some basic steps you can 
follow to make sure you translate those changes to the new skin properly.

Table 8:  Commonly Customized Reverb Files

Filename
The display area or items affected by this 
file

webworks.css Content panel styling only. 
Includes the styling of the 
MiniTOC, RelatedTopics, Social 
Buttons.

skin.css Styling of TOC, Index, Toolbar, 
and Breadcrumbs. All icons used in 
the skin.png sprite file are 
managed here. Styling of content 
that appears above the Toolbar, 
such as the company information.

search.css Styling of the search results 
page.

skin.png (derived from skin.Fireworks.png) PNG file with alpha channel that stores all of 
the Reverb icons.

connect.asp Used to manage the button placement in the 
toolbar. Also manages the TOC/Index/Search 
panel title for the Corporate skin.

connect.css Manages basic structure of the entry-point file 
generated from the connect.asp template 
file.
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Basic steps for setting an alternate skin type when Advanced customizations 
are present

1. Check your Advanced Customizations for files listed in “Commonly Customized 
Reverb Files” on page 37.

2. Make sure any of these commonly customized files are implemented as Target 
Overrides as opposed to Format Overrides. Setting an alternate skin type will 
create an implicit target override that will have priority over any format overrides of 
the same name.

3. Before changing the skin type you will need to record any existing file differences. 
On the Advanced menu click Manage Target Customizations. Now use the 
procedure discussed in “Managing Format/Target Overrides” on page 429 to record 
these file differences. These file differences will be used later after the skin type has 
been changed.

4. On the Target menu, click Target Settings.

5. In the WebWorks Reverb category, select the right column of the Skin entry to 
display the file picker button.

6. Click the file picker button to bring up an Open file dialog which will display a list 
of skin plugin files. Each skin plugin file is identifiable by a .weplugin extension.

7. Browse to the plugin file that you wish to use and double-click it to set the skin to 
that value.

8. At this point, you need to consider either removing your existing customizations 
and then re-implementing them using the information from your previously 
recorded file differences. Or managing the differences directly by comparing the 
differences using the procedure discussed in “Managing Format/Target Overrides” 
on page 429. Either method will work.

Uninstalling ePublisher

If you are installing an ePublisher component that is of version 2009.3 or higher and your 
currently installed component is version 2009.2 or higher, then your component will 
automatically be uninstalled for you. Otherwise, before installing a new version of an 
ePublisher component, you must uninstall any previous versions of the component. 
Uninstalling an ePublisher component removes the installation folder and registry entries 
for the component from the computer. 

If ePublisher installed the WebWorks Transit menu for Microsoft Word on the 
computer, ePublisher removes the WebWorks Transit menu and WebWorks Transit 
registry entries when you uninstall the last ePublisher component on the computer.
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To uninstall an ePublisher component

1. Close all ePublisher user interfaces.

2. Close all instances of Microsoft Office applications running on the local computer, 
including instances of Microsoft Word and Microsoft Outlook. Close all instances 
of Adobe FrameMaker running on the computer.

3. Open Control Panel.

4. Open Add or Remove Programs.

5. Select the ePublisher component you want to uninstall.

6. Click Remove.

7. Click Yes to confirm you want to remove the ePublisher component from your 
computer. ePublisher removes the selected ePublisher component.

Troubleshooting Installation, License Keys, and 
Uninstallation

This section helps you troubleshoot issues related to the following ePublisher issues:

• Installing ePublisher. For more information, see “Problems Installing ePublisher” 
on page 40.

• Obtaining, adding, and removing Contract IDs and working with licensing. For 
more information, see “Problems with Contract IDs and Licensing” on page 42.

• Uninstalling ePublisher. For more information, see “Problems Uninstalling 
ePublisher” on page 42.
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Problems Installing ePublisher

This section helps you troubleshoot issues related to installing ePublisher.

Error: Microsoft .NET Framework 2.0 Not Installed

If you are installing an ePublisher component and you do not have the Microsoft .NET 
Framework installed, ePublisher displays the following error message.

To resolve this issue

1. Click Yes. ePublisher redirects you to the Microsoft .NET Framework Web site.

2. Download and install the Microsoft .NET Framework Redistributable Package. You 
do not need to download and install the Microsoft .NET Framework Software 
Development Kit.

Error: Please Close all Running Sessions of Microsoft Word

If you have any Microsoft Office processes running when installing ePublisher, including 
instances of Microsoft Word and Microsoft Outlook, ePublisher displays the following 
error message.
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To resolve this issue

1. Close any running instances of Microsoft Word.

2. Close Microsoft Outlook.

3. Open Task Manager.

4. Click on the Processes tab.

5. Search for WINWORD.EXE. You can click on the Image Name column to sort the 
processes alphabetically.

6. If there is a WINWORD.EXE process running, complete the following steps:

a. Select WINWORD.EXE.

b. Click End Process to close all running Word processes. Task Manager 
displays the following warning.

c. Click Yes.

d. Close Task Manager, and then proceed with your ePublisher installation.
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7. If there are no WINWORD.EXE processes running, proceed with your ePublisher 
installation.

Problems with Contract IDs and Licensing

This section helps you troubleshoot issues related to obtaining, adding, and removing 
Contract IDs. For more information about Contract IDs, see “Working with Contract IDs” 
on page 29.

No Contract ID Received

After you purchase ePublisher components, your WebWorks customer service team will e-
mail your Contract ID that enables licensing for the products your purchased. If you have 
not received a Contract ID, send an email to sales@webworks.com. For more information 
about Contract IDs, see “Working with Contract IDs” on page 29.

Error: No Valid License Key Found

You must enter a Contract ID before you can generate output. If you have not entered your 
Contract ID information, ePublisher displays an error stating that no valid license key was 
found to enable support for your content authoring tool.

If you have entered a Contract ID but still receive this error, verify you entered your 
Contract ID information correctly. For more information about Contract IDs, see 
“Working with Contract IDs” on page 29.

Other Contract ID and Licensing Problems

If you have received your Contract ID and entered your Contract ID into ePublisher but 
you are having problems with licensing, send an email to 
customerservice@webworks.com. For more information about Contract IDs, see 
“Working with Contract IDs” on page 29.

Note: ePublisher licensing is flexible, and the WebWorks team can work with you ensure 
that you have the licensing that is right for you.

Problems Uninstalling ePublisher

This section helps you troubleshoot issues related to uninstalling ePublisher.
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Error: You Must Remove the Previous Version of ePublisher

If you try to install a new version of an ePublisher component before uninstalling the 
previous version of an ePublisher component, ePublisher displays an error message telling 
you need to remove the previous version of the ePublisher component before you can 
install the new version of the component. ePublisher should no longer display this error 
once you uninstall the previous version of the component.

If after you uninstall an ePublisher component, you still receive an error when you try to 
install a new version of the component, confirm that the component is no longer listed in 
the Add or Remove Programs list in Control Panel. If the component is no longer listed 
but you still receive the error, there may still be some registry keys from the prevision 
installation on the computer that are preventing you from installing a new version of the 
ePublisher component.

To resolve this issue

1. Log on to the WebWorks technical support site at 
http://www.webworks.com/Technical_Assistance/My_Cases/.

Note: You must have an active maintenance agreement in order to log on to the 
WebWorks technical support site.

2. On the Find Solution tab, in the Search for field, type Problems installing or 
upgrading ePublisher component, and then click Find Solution.

3. Open the Knowledge Base article.

4. Click the Remove WebWorks registry file link.

5. Download the .zip file.

6. Unzip the file and then run the .reg file.

7. Follow the instructions to remove any problematic keys. No other changes will be 
made to your computer.

Problems Completely Uninstalling ePublisher

If you have a problem uninstalling an ePublisher component, first ensure that no registry 
keys from the previous version of the component remain on your computer. For more 
information, see “Error: You Must Remove the Previous Version of ePublisher” on 
page 43. If after removing all registry key entries from the previous version you still are 
unable to completely uninstall ePublisher, download and install the Windows Installer 
Cleanup Utility. The Windows Installer Cleanup Utility allows you to completely remove 
ePublisher Express from your system.
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To completely remove ePublisher using the Windows Installer Cleanup 
Utility

1. Download and install the Windows Installer Cleanup Utility. The Windows Installer 
Cleanup Utility is available on the Microsoft Web site at 
http://support.microsoft.com/?scid=kb;en-us;290301.

2. Open the Windows Installer Cleanup Utility.

3. Find and select the ePublisher component from the list of installed products.

4. Click Remove.

5. A windows displays and alerts you that ePublisher component will be deleted from 
the Windows Installer database. Click OK to remove the ePublisher component.

6. Browse to Program Files\WebWorks on your local computer.

7. Verify that the ePublisher component is no longer in the folder. If the folder still 
exists, delete it.

Other Errors Uninstalling ePublisher

If you have already tried to completely uninstall the ePublisher component using the 
Windows Installer Cleanup Utility but you are still receiving errors, submit a support 
request on the WebWorks Web site at http://www.webworks.com/Support/My_Cases.
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Exploring ePublisher

This section helps you understand the ePublisher workflow, from the tasks that the 
Stationery designer performs, such as preparing source document templates and creating 
Stationery, through the tasks that writers perform, such as preparing their source 
documents for output generation, generating output, and validating their generated output.

This section also provides an overview of each ePublisher user interface and, through the 
use of sample Exploring ePublisher source documents, projects, and Stationery, helps you 
understand how you can quickly and easily produce online content that meets required 
styles and standards 

Understanding the ePublisher Workflow

ePublisher allows your organization to quickly and easily produce online content that 
meets your organization’s styles and standards. With ePublisher, you use the following 
workflow to quickly and easily generate online content:

• Stationery designers create new or modify existing source document templates and 
then use ePublisher Designer to create Stationery for writers to use to generate 
output. For more information, see “Stationery Designers and ePublisher Designer” 
on page 46.

• Writers use ePublisher Express and the Stationery created by a Stationery designer 
to generate and validate online content. For more information, see “Writers and 
ePublisher Express” on page 47.

• ePublisher AutoMap can automatically generate and deploy online content using 
the Stationery created by a Stationery designer and source documents created by 
writers. For more information, see “Automating Output Generation with ePublisher 
AutoMap” on page 48.
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Stationery Designers and ePublisher Designer

If you are a Stationery designer, your first step when you work with ePublisher will be to 
identify which input formats will be used to author source documents, which types of 
output need to be generated, and which online features should be included in generated 
output. For more information, see “Supported Input Formats” on page 3, “Supported 
Output Formats” on page 4, and “Features Available in Each Output Format” on page 9.

After you identify your input and output formats and the features you want to include in 
your online content, your next step is to either create source document templates or 
prepare your existing source document templates for output generation. Stationery 
designers use source document templates to configure settings and create Stationery for 
writers to use when generating output. Writers use the source document templates to 
create content and prepare source documents for output generation. If writers already use 
source document templates, Stationery designers can simply prepare the existing source 
document templates for output generation. If writers are not currently using source 
document templates, the Stationery designer creates a source document template for each 
content authoring tool content used by the authors in the organization. Writers then use the 
styles and standards defined in the template to prepare their source files for output 
generation.

For example, if all writers use Adobe FrameMaker and Adobe FrameMaker templates 
when authoring content, the Stationery designer can take the existing Adobe FrameMaker 
templates, modify the templates as needed to support online content, and then use the 
existing templates to create Stationery. If writers use both Adobe FrameMaker and 
Microsoft Word but are not yet consistently using templates, the Stationery designer 
creates a new standard set of both Adobe FrameMaker and Microsoft Word templates for 
writers to use when authoring content. For more information about preparing source 
document templates for output generation, see the ePublisher Design Guide. 

After the Stationery designer prepares source document templates for the content 
authoring tools writers use, the Stationery designer uses ePublisher Designer to perform 
the following tasks:

• Create a Stationery design project using the source document templates.

• Configure settings and options in the Stationery design project that define the look, 
feel, and behavior for each output target.

For example, the Stationery designer can specify if ePublisher should use the 
existing styles and formatting in the source documents when generating output to 
ensure the source documents and online content share the same look and feel. The 
Stationery designer can also specify that online content have a completely different 
look and feel than the source documents based on online output design goals and 
business needs.

• Create Stationery using the settings defined in the Stationery design project. The 
Stationery defines the style and behavior of generated output, and writers use the 
settings in the Stationery when they generate output from their source documents.
46  Chapter 3: Exploring ePublisher Evaluation Guide



Understanding the ePublisher Workflow
After the Stationery designer creates the Stationery, the Stationery designer places the 
ePublisher Stationery and source document template files on a shared network folder for 
writers to use as they author their content, prepare their source documents for output 
generation, and generate output.

Writers and ePublisher Express

With ePublisher, writers use their preferred content authoring tool and the source 
document templates provided by the Stationery designer to create content and prepare 
their source documents for output generation. Writers can use Microsoft Word, structured 
or unstructured Adobe FrameMaker, and DITA-XML content authoring tools to author 
content. Writers format, or tag, their source documents by applying styles and formats, 
and then ePublisher uses this information to generate the appropriate output based on the 
settings the Stationery designer specified in the Stationery. Writers do not need to worry 
about output design. Instead, writers can focus on creating the content users need.

When writers are ready to generate online content, writers use ePublisher Express to 
perform the following tasks:

• Create an ePublisher Express project based on Stationery created by a Stationery 
designer.

• Add the source documents they want to use to generate output to the ePublisher 
Express project.

• Generate output. The output writers generate adheres to the styles and standards 
defined by the Stationery designer in the Stationery. Writers can generate output on 
demand. ePublisher can also automatically generate output based on a schedule if 
ePublisher AutoMap is implemented.

• Deploy generated output. Writers can deploy their generation to a Web site or to a 
central location from which a product build can obtain the files. ePublisher can 
automatically deploy output if ePublisher AutoMap is implemented.

• Check the generated output into a version control system or copy the generated 
output to a central archive location.

Although writers typically use the Stationery provided by the Stationery designer without 
modification, writers can use ePublisher Express to perform some customizations of 
output target settings if they have target setting modification permissions. For example, 
writers can customize company information such as company name, phone number, and 
Web site information in their generated output if they have target setting modification 
permissions. If writers need to customize any target or project settings, they should first 
ensure they have appropriate target setting modification permissions. After they make any 
target setting customizations, they regenerate their output and verify their target setting 
customizations before deploying their final output. For more information about target 
setting permissions and modifying target settings, see the ePublisher Writer Guide. 
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Most writers prefer to use ePublisher Express to perform an initial output generation early 
in their project cycle. This allows writers to quickly and easily verify that they are 
formatting their source documents correctly and also confirm that their generated output 
has the appearance and features they want. After an initial verification of the generated 
output early in the project cycle, writers continue to add content to their source documents, 
then regenerate output on a periodic basis, such as once a week, as the project progresses. 

If ePublisher AutoMap is implemented, ePublisher AutoMap can be configured to 
automatically generate output for writers on a regular schedule. For example, ePublisher 
AutoMap can be configured to automatically generate output for a project every night. 
When writers arrive at work the next day, writers can quickly and easily verify that the 
latest content they added to their source documents is formatted correctly and displays 
appropriately in their generated output. Periodic output generation using the latest version 
of source documents and Stationery provides the following benefits:

• Allows writers to quickly and easily confirm that they are formatting their source 
documents correctly and feel confident that their generated output always conforms 
to the standards and styles defined in their project Stationery by the Stationery 
designer

• Reduces the amount of time writers spend doing a quality assurance review for their 
generated output at the end of a project cycle

• Helps eliminate post-generation editing and processing, which save organizations 
time and money

• Ensures that the end of the project cycle is smooth and hassle-free

ePublisher allows writers to quickly and easily produce high-quality output according to 
specifications each time they generate output.

Automating Output Generation with ePublisher AutoMap

If you implement ePublisher AutoMap, you can configure ePublisher AutoMap to 
automate your output generation using Stationery created by a Stationery designer and 
source documents created by writers. For more information about ePublisher AutoMap, 
see the ePublisher Design Guide. 
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Exploring the ePublisher User Interfaces

The WebWorks ePublisher Platform provides the following user interfaces:

• ePublisher Express user interface, which writers use when generating output

• ePublisher Designer user interface, which Stationery designers use when creating 
and updating Stationery

• ePublisher AutoMap user interface, used to automate output generation and 
integrate the output generation process with source control systems and product 
build systems

This section provides an overview of each of these ePublisher user interfaces.

Exploring the ePublisher Express User Interface

The ePublisher Express user interface includes the following windows:

• Start page. For more information, see “Understanding the Start Page” on page 51.

• Document Manager. For more information, see “Understanding Document 
Manager” on page 53.

• Output Explorer. For more information, see “Understanding Output Explorer” on 
page 55.

• Log Window. For more information, see “Understanding the Log Window” on 
page 57.
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The following figure shows the ePublisher Express user interface.

Exploring the ePublisher Designer User Interface

The ePublisher Designer user interface includes the following windows:

• Start page. For more information, see “Understanding the Start Page” on page 51.

• Document Manager. For more information, see “Understanding Document 
Manager” on page 53.

• Output Explorer. For more information, see “Understanding Output Explorer” on 
page 55.

• Log Window. For more information, see “Understanding the Log Window” on 
page 57.

• Style Designer. For more information, see “Understanding Style Designer” on 
page 57.

• Preview window. For more information, see “Understanding the Preview Window” 
on page 58.
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The following figure shows the ePublisher Designer user interface.

Understanding the Start Page

The Start page is available in both ePublisher Express and ePublisher Designer. The Start 
page lists the most recently opened ePublisher projects. You click on a project name on the 
Start page to open the associated project file. You can also specify the number of projects 
you want to display on the Start page. For more information about specifying the number 
of projects you want to display on the Start page, see “Specifying General ePublisher 
Preferences” on page 89.
Evaluation Guide Chapter 3: Exploring ePublisher  51



Exploring the ePublisher User Interfaces
The following figure shows the Start page.
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Understanding Document Manager

Document Manager is available in both ePublisher Express and ePublisher Designer. 
Document Manager allows you to organize the source documents in your project. Within 
Document Manager, you can add, remove, and rearrange the groups and source documents 
in your project. For more information about working with source documents in Document 
Manager, see the ePublisher Writer Guide or the ePublisher Design Guide. The following 
figure shows Document Manager.

Including or Excluding Files

ePublisher allows you to include/exclude documents from processing on a target by target 
basis. This capability is available to all ePublisher users, regardless of their source 
authoring format. Users working with Adobe FrameMaker 9 and later book files will see 
that ePublisher scans default include/exclude values from their source documents.
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To include or exclude a document from processing, right-click on any file or book. The 
context menu will appear with the Include/Exclude option. Clicking this item will reveal 
three choices: Include, Exclude and Use Document Value. Clicking Exclude will create 
a red dotted line around the file that will indicated that this source file will not be created 
in the output file. Clicking include will show as normal and if it is not changed in the FM 
source, will be included. The Use Document Value will take whatever is set in 
FrameMaker and if already set to Exclude in the source will show the dotted red lines 
around the source documents.

Note: Include/exclude settings are configured on a per Target. For example in this 
project’s WebWorks Help target, ecology.book (along with all child files) is 
excluded: 

In the same project’s WebWorks Reverb target, ecology.book book is included for 
processing while Exploring ePublisher.book (and child files) is excluded. 
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Understanding Output Explorer

Output Explorer is available in both ePublisher Express and ePublisher Designer. Output 
Explorer displays all of the files generated by ePublisher. 

The following figure shows Output Explorer.

Top Level Group
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The output files displayed in the Output Explorer depend on the item you select in 
Document Manger. Output Explorer displays items as follows:

• If you have a source document selected in Document Manager, ePublisher 
displays the source document group in Output Explorer. The source document 
group displayed in Output Explorer contains the Files group, which lists all of the 
generated topic files, the Images group, which lists all of the generated images for 
your output, and the Reports group, which lists Styles, Links, Accessibility, 
Filenames, and Topics reports.

• If you have a top-level group selected in Document Manager, ePublisher displays 
the top-level group in Output Explorer. The top-level group displayed in Output 
Explorer contains the Navigation group, which lists the entry-point file for the 
generated output based on the active target selected in the project, and the Reports 
group, which lists Styles, Links, Accessibility, Filenames, and Topics reports.

• If you have a subgroup selected in Document Manager, ePublisher displays the 
subgroup in Output Explorer. The subgroup contains the entry-point file for the 
generated output.

If you have more than one top-level group in Document Manager, in addition to 
displaying the top-level group you select in Document Manager in Output Explorer, 
ePublisher also displays a Merge Output group in Output Explorer. The Merge 
Output group displays the merged entry-point file created from each top-level group 
entry point file. You can use the merged entry-point file ePublisher automatically 
creates when you have more than one top-level group in Document Manager to 
created merged help systems.

For more information about merged help systems, see the ePublisher Writer Guide 
or ePublisher Design Guide.  
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Understanding the Log Window

The Log Window is available in both ePublisher Express and ePublisher Designer. The 
Log Window displays the log ePublisher creates when generating output. When 
ePublisher creates a log during output generation, you can see the status of the output 
generation process and any errors generated. You can also quickly and easily see which 
pipelines ePublisher processed, which settings ePublisher applied, and which files 
ePublisher parsed. For more information about viewing and working with logs, see the 
ePublisher Writer Guide or ePublisher Design Guide.   The following figure shows the 
Log Window.

Understanding Style Designer

Style Designer is available in only ePublisher Designer. ePublisher intelligently discovers 
the styles in the source documents and presents a list of these styles in Style Designer. 
Stationery designers then define how output should be generated by specifying properties 
and options for each style. Stationery designers use Style Designer to define how 
paragraphs, characters, tables, and images display in generated output, including the color 
or font of a paragraph style, the style of a table border, the layout of a page, and the file 
format of converted images. Stationery designers can also specify other aspects of 
generated output, such as page layout and when topic pages are created.

ePublisher uses the styles in source documents along with the settings the Stationery 
designer defines in the Stationery to generate output. Using styles in source documents 
and Stationery settings allows precise control over the appearance and behavior of 
generated output.
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The following figure shows Style Designer.

Understanding the Preview Window

The Preview window is available in only ePublisher Designer. When designing Stationery, 
Stationery designers can use the Preview window to quickly see how modifications made 
to styles and project settings affect the appearance of generated output. You can generate a 
preview of output from a source file in ePublisher Designer when you select a source 
document in Document Manager. However, some online content features, such as popup 
windows, links, and conditions, are not displayed or active in the Preview window. 
58  Chapter 3: Exploring ePublisher Evaluation Guide



Exploring the ePublisher User Interfaces
The following figure shows the Preview window.

For more information about using the preview window in ePublisher Designer when 
designing Stationery, see the ePublisher Design Guide.  
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Exploring the ePublisher AutoMap User Interface

The ePublisher AutoMap user interface allows you to create, edit, and schedule ePublisher 
AutoMap jobs. The following figure shows the ePublisher AutoMap user interface.

For more information about using ePublisher AutoMap, see the ePublisher Design Guide. 

Exploring ePublisher Using Sample Source 
Documents, Projects, and Stationery

When you request an evaluation of ePublisher, you will receive information about how 
you can download an evaluation version of ePublisher Express, along with an evaluation 
Contract ID. You can request an evaluation of ePublisher by completing the form available 
on the WebWorks Web site at: http://www.webworks.com/Tour/Try_ePublisher/ or by 
calling Quadralay. For more information about contacting Quadralay, see “Contacting 
Quadralay” on page vii. After you submit your request you will receive an email with 
instructions on how to download your ePublisher Express evaluation copy and use the 
evaluation Contract ID.

Once you install ePublisher Express, you can use the sample Exploring ePublisher 
Express project, source documents and Stationery to help you explore and understand 
ePublisher capabilities. ePublisher installs the sample Exploring ePublisher project and 
source documents in the My Documents\ePublisher Express Projects\Exp_ePub 
folder on the same computer. In addition, ePublisher also installs sample Stationery in the 
My Documents\ePublisher Stationery\Exp_Stationery folder. The Exploring 
ePublisher Express project, source documents and Stationery allow you to produce output 
in WebWorks Help, WebWorks Reverb, eBook - ePUB 2.0, PDF, Microsoft HTML Help, 
and Dynamic HTML using Stationery configured by a Stationery designer. 
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After you explore ePublisher capabilities using sample Exploring ePublisher Express 
project, source documents, and Stationery, you can learn more about the ePublisher 
workflow and Stationery design process by reviewing the ePublisher Design Guide. After 
you review the ePublisher Design Guide, if you would like to use ePublisher Designer to 
create your own Stationery as part of your ePublisher evaluation process, contact a 
WebWorks sales representative for more information. You can contact a WebWorks sales 
representative by completing the form available on the WebWorks Web site at 
http://www.webworks.com/Company/Contact/ or by calling Quadralay. For more 
information about contacting Quadralay, see “Contacting Quadralay” on page vii.

Checklist: Exploring ePublisher and Producing Output

Use the following checklist to help you use ePublisher Express and the sample Exploring 
ePublisher source documents and Stationery to explore ePublisher and produce output.

Task

1. Install ePublisher Express. When you install ePublisher Express, ensure you select the 
check box that allows you to modify target settings, condition settings, variable values, 
and cross-reference definitions. For more information, see “Installing ePublisher” on 
page 23.

2. Add the sample Exploring ePublisher source documents to the sample ePublisher 
Express project. For more information, see “Adding Sample Source Documents to the 
Exploring ePublisher Project” on page 65.

3. Review the sample Exploring ePublisher source documents to get an understanding of 
how the source documents are formatted to support online features in generated output. 
For more information, see “Reviewing Sample Exploring ePublisher Source Documents” 
on page 67.

4. Use the sample Exploring ePublisher Express project and the sample Exploring 
ePublisher source documents and Stationery to generate output. For more information, 
see “Generating Output Using the Exploring ePublisher Project” on page 68

5. Review your generated output. For more information, see “Reviewing Exploring 
ePublisher Generated Output” on page 69.

6. Customize your Exploring ePublisher output. For more information, see “Customizing 
Exploring ePublisher Output” on page 74.

7. Implement online features such as popup windows, expand/collapse sections, related 
topics, and context-sensitive help topics using the sample Exploring ePublisher source 
documents and Stationery. For more information, see “Implementing Online Features 
Using Sample Source Documents and Stationery” on page 80.
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Producing Output Using Sample Source Documents 
and Stationery

This section explains how you can use sample Exploring ePublisher source documents and 
Stationery to learn more about how ePublisher works and how you can use ePublisher to 
quickly and easily generate and deliver online content that conforms to the online content 
styles and standards specified for your organization.

Resetting Evaluation Materials

The sample source documents are considered by ePublisher to be your work, so 
ePublisher’s installation mechanism will never overwrite previously existing versions of 
these files. If you are upgrading from a prior release of ePublisher, then you may want to 
reset the evaluation materials so that they are the latest version.

1. Select the Edit -> Preferences Menu

2. Select the Reset Evaluation Materials button
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Understanding the Sample Source Documents and Stationery

When writers work with ePublisher in a real-world environment, writers use their source 
documents and source document templates and Stationery provided by a Stationery 
designer to generate output.

However, this section assumes that you are using the sample Exploring ePublisher source 
documents and Stationery provided for you when you install ePublisher to generate 
output. Using the sample Exploring ePublisher source documents and Stationery allows 
you to see how quickly and easily writers can generate output using ePublisher Express 
and Stationery designed by a Stationery designer. Using the sample Exploring ePublisher 
source documents and Stationery also means that you do not have to create your own 
sample source document templates and Stationery in order to generate output.

When you explore ePublisher using the provided sample source documents and Stationery, 
you use sample source documents and Stationery created by a Stationery designer to 
generate output. These sample source documents were created using Adobe FrameMaker 
and Microsoft Word template files the Stationery designer created for use with the 
Exploring ePublisher Stationery. The Stationery designer used ePublisher Designer to 
create the Exploring ePublisher Stationery you received by performing the following 
tasks:

1. Created Adobe FrameMaker and Microsoft Word templates that specified the 
paragraph and character formats, styles, conditions, and marker types for writers to 
use when authoring content in source documents. For more information about 
creating Adobe FrameMaker and Microsoft Word templates, see the ePublisher 
Design Guide.  

2. Created a Stationery design project. For more information about creating a 
Stationery design project, see the ePublisher Design Guide.  
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3. Specified WebWorks Help - Exploring ePublisher, Microsoft HTML Help -
 Exploring ePublisher, and Dynamic HTML - Exploring ePublisher as target output 
formats. For more information about specifying output formats and targets, see the 
ePublisher Design Guide.  

4. Used Style Designer to perform the following tasks:

• Defined page breaks to create a new page for each Chapter Title, Heading1, 
Heading2, and Heading3 style.

• Defined the table of contents structure, or levels, for the generated output.

• Disabled autonumbering for chapter titles.

• Specified that cross-references display as headings with page numbers in 
source documents, and display as hyperlinks without page numbers in 
generated output.

• Defined popup window styles by completing the following tasks:

Note: Dynamic HTML does not support popup windows.

– Defined the GlossTerm and GlossDef paragraph styles so that any 
content with this style applied displays in a popup window.

– Assigned a page style for popup windows.

• Defined the ExpandCollapse style so that any content with this style applied 
displays as a link, and when users click the link, the content below the link 
displays until the point where the writer inserts a DropDownEnd marker.

• Defined the RelatedTopics style so that any content with this style displays as 
a related topic link in generated output when users click a related topics 
button in the generated output.

• Defined a TopicAlias marker so that any topic that contains this marker has a 
unique ID that an application can use to display a context-sensitive help topic 
when users click on a Help button from within the application.

• Enabled the display of company information in the bottom right of each 
generated output page. This allows writers to enter the appropriate company 
information as needed in their generated output.

• Specified that the generated output display using the same fonts specified in 
the source documents. By default, ePublisher generates output using the 
same fonts and paragraph and character styles and formats used in the source 
documents. However, Stationery designers can also configure the Stationery 
to use a completely different look in the generated output.
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• Specified that browse sequence buttons display in the generated output. By 
default, ePublisher creates previous and next browse sequence buttons that 
automatically set the browse sequence to the same page as the order of topics 
in the table of contents. Users can use these buttons to click through online 
content in the order of the table of contents.

• Configured the Stationery to ignore front matter in source documents such as 
title pages and table of contents pages.

• Configured a passthrough condition to use when embedding code that 
references multimedia files in source documents.

For more information about using Style Designer to perform these tasks, see the 
ePublisher Design Guide.  

5. Saved the Stationery and performed a test output generation using the sample 
template files to confirm that the Stationery generates output correctly. For more 
information, see the ePublisher Design Guide.  

6. Deployed the Stationery for other writers to use to generate output. For more 
information, see the ePublisher Design Guide.  

Adding Sample Source Documents to the Exploring ePublisher Project

Add the sample Exploring ePublisher source documents to the sample Exploring 
ePublisher Express project. The sample Exploring ePublisher Express project uses the 
sample Exploring ePublisher Stationery configured by the Stationery designer. After you 
add the sample Exploring ePublisher source documents to the sample Exploring 
ePublisher project, you will generate output using the sample Exploring ePublisher source 
documents and Stationery. Generating output will help you understand how writers can 
use ePublisher Express and Stationery created by a Stationery designer to quickly and 
easily generate output from their source documents.

To add sample source documents to the Exploring ePublisher project

1. Open ePublisher Express.

2. On the File menu, click Open.

3. Browse to the My Documents\ePublisher Express Projects\Exp_ePub folder.

4. Select the Exploring ePublisher Project.wrp file, and then click Open.

5. If ePublisher displays a message asking you if you would like to synchronize the 
project with the Stationery, click OK. ePublisher synchronizes the project with the 
Stationery.
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6. If you use Adobe FrameMaker to create your source documents, complete the 
following steps:

a. In Document Manager, click Exploring ePublisher Project.

b. On the Project menu, click Add Document.

c. Browse to the My Documents\ePublisher Express 
Projects\Exp_ePub\Source-Docs\Adobe FrameMaker folder, select the 
Exploring ePublisher.book file, and then click Open. ePublisher displays 
the source documents you added to the project in Document Manager.

7. If you use Microsoft Word to create your source documents, complete the 
following steps:

a. In Document Manager, click Exploring ePublisher Project.

b. On the Project menu, click Add Document.

c. Browse to the My Documents\ePublisher Express 
Projects\Exp_ePub\Source-Docs\Microsoft Word folder, select the 
Exploring ePublisher.doc file, and then click Open. ePublisher displays 
the source documents you added to the project in Document Manager.

8. On the File menu, click Save.

After you add source documents to the Exploring ePublisher project, complete the 
following actions:

• Review the sample Exploring ePublisher source documents. For more information, 
see “Reviewing Sample Exploring ePublisher Source Documents” on page 67.

• Generate output. For more information, see “Generating Output Using the 
Exploring ePublisher Project” on page 68.

• Review the generated output. For more information, see “Reviewing Exploring 
ePublisher Generated Output” on page 69.

• Customize the output. For more information, see “Customizing Exploring 
ePublisher Output” on page 74.

• Implement online features such as popup windows, expand/collapse sections, 
related topics, and context-sensitive help topics. For more information, see 
“Implementing Online Features Using Sample Source Documents and Stationery” 
on page 80.
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Reviewing Sample Exploring ePublisher Source Documents

Review the sample Exploring ePublisher source documents you included in the Exploring 
ePublisher project. You will use the sample Exploring ePublisher source documents to 
generate output using the Exploring ePublisher Stationery. Reviewing the sample source 
documents before you generate output will help you understand how writers prepare their 
source documents when they want to implement features such as popup windows, 
expand/collapse sections, related topics, and context-sensitive help topics in their 
generated output.

To review the sample Exploring ePublisher source documents

1. If you added the Adobe FrameMaker Exploring ePublisher.book source 
document, in Document Manager, double-click the Exploring ePublisher.book 
file. ePublisher opens the Exploring ePublisher.book file.

2. If you added the Microsoft Word Exploring ePublisher.doc source document, 
complete the following steps:

a. Double-click the Exploring ePublisher.doc file. ePublisher opens the 
Exploring ePublisher.doc file.

b. On the Tools menu, click Options.

c. On the View tab, in the Formatting marks area, select the Hidden text 
check box, and then click OK.

When writers format Microsoft Word source documents for output generation, 
Microsoft Word inserts some of the items writers use as hidden text. Displaying the 
hidden text in the Microsoft Word source documents helps you quickly and easily 
see online content formatting elements added to the Microsoft Word source 
documents.

3. Review source document contents to become familiar with the content and the 
styles and formatting used in the source documents. After you review the source 
documents, generate output.
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Generating Output Using the Exploring ePublisher Project

After you have added the Exploring ePublisher source documents to your ePublisher 
Express project and reviewed the source documents, generate output for the following 
output formats using your Exploring ePublisher project:

• WebWorks Help

• WebWorks Reverb

• Microsoft HTML Help

• Dynamic HTML

• PDF

• eBook - ePUB 2.0

ePublisher provides support for a large variety of output formats, such as simple and 
Dynamic HTML, Sun JavaHelp, Oracle Help, Eclipse Help, PDFs, Wikis, Microsoft 
Reader, Palm Reader, and more. You can produce output for all of these different formats 
using a single set of source documents in just a few clicks.

The sample Exploring ePublisher source documents and Stationery provide examples of 
how online features such as popup windows, expand/collapse sections, related topics, and 
context-sensitive help topics display in generated output. After you generate and review 
the Exploring ePublisher generated output, you can customize target settings in ePublisher 
to further customize the look and feel of the generated output. For more information, see 
“Customizing Exploring ePublisher Output” on page 74.

To generate output using the Exploring ePublisher project

1. On the Project menu, click Scan All Documents.

2. Generate WebWorks Help by completing the following steps:

a. On the Project menu, select the WebWorks Help - Exploring ePublisher 
target next to Active Target.

b. On the Project menu, click Generate All. ePublisher displays the Log 
Window and generates output.

c. If you want to quickly review the generated output, click Yes. You will also 
review the generated output in more detail in a following task. For more 
information, see “Reviewing Sample Exploring ePublisher Source 
Documents” on page 67.
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3. Generate Microsoft HTML Help by completing the following steps:

a. On the Project menu, select the Microsoft HTML Help - Exploring 
ePublisher target next to Active Target.

b. On the Project menu, click Generate All.

c. If you want to quickly review the generated output, click Yes. You will also 
review the generated output in more detail in a following task. For more 
information, see “Reviewing Sample Exploring ePublisher Source 
Documents” on page 67. 

4. Generate Dynamic HTML by completing the following steps:

a. On the Project menu, select the Dynamic HTML - Exploring ePublisher 
target next to Active Target.

b. On the Project menu, click Generate All.

c. If you want to quickly review the generated output, click Yes. You will also 
review the generated output in more detail in a following task. For more 
information, see “Reviewing Sample Exploring ePublisher Source 
Documents” on page 67.

Reviewing Exploring ePublisher Generated Output

The sample Exploring ePublisher source documents and Stationery provide examples of 
how the following online features display in generated output:

• Popup windows

• Expand/collapse sections

• Related topics

• Context-sensitive help topics 

Review the output you generated using the sample Exploring ePublisher source 
documents and Stationery to learn more about these items. After you review the Exploring 
ePublisher generated output, you can customize target settings in ePublisher to further 
customize the look and feel of the generated output. For more information, see 
“Customizing Exploring ePublisher Output” on page 74.
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To review the Exploring ePublisher generated output

1. In Document Manager, select the Exploring ePublisher Project top-level group. The 
following figure shows the Exploring ePublisher Project top-level group selected in 
Document Manager.

2. If you want to review generated output for WebWorks Help, complete the 
following steps:

a. On the Project menu, select the WebWorks Help - Exploring ePublisher 
target next to Active Target.

b. In Output Explorer, under Navigation, double-click index.html entry-point 
file to open the WebWorks Help system.

Note: By default, WebWorks Help displays a default WebWorks logo on the 
first page, also known as the splash page, of a WebWorks Help system. 
You can quickly and easily replace the default WebWorks logo used on 
the splash page with your own company logo, or you can choose not to 
use a splash page, and show the first help topic instead. For more 
information about customizing the splash page in WebWorks Help, see 
“Customizing Exploring ePublisher Output” on page 74.

3. If you want to review generated output for Microsoft HTML Help, complete the 
following steps:

a. On the Project menu, select the Microsoft HTML Help - Exploring 
ePublisher target next to Active Target.

b. In Document Manager, select the Exploring ePublisher top-level group.

c. In Output Explorer, under Navigation, double-click the Exploring 
ePublisher.chm entry-point file to open the Microsoft HTML Help system.
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4. If you want to review generated output for Dynamic HTML, complete the 
following steps:

a. On the Project menu, select the Dynamic HTML - Exploring ePublisher 
target next to Active Target.

b. In Document Manager, select the Exploring ePublisher top-level group.

c. In Output Explorer, under Navigation, double-click the toc.html entry-
point file to open the Dynamic HTML.

5. On the Contents tab, note that ePublisher created a new topic page for each section 
of the document with a Chapter Title, Heading1, Heading2, or Heading3 format or 
style applied.

6. Click one of the following topics:

• If you generated output using the FrameMaker source document, click the 
Sample Source Documents and Stationery (FrameMaker) topic.

• If you generated output using the Word source document, click the Sample 
Source Documents and Stationery (Word) topic.

7. Note that although a chapter number displays in front of this heading in the source 
document, a chapter number does not display in front of this heading in the 
generated output. The Stationery designer configured the Stationery not to display 
chapter numbers in generated output because chapter numbers are out of context in 
online content.

8. Click one of the following topics:

• If you generated output using the FrameMaker source document, click the 
Sample Source Documents and Stationery (FrameMaker) > Adding 
Functional Elements to Online Content (FrameMaker) topic.

• If you generated output using the Word source document, click the Sample 
Source Documents and Stationery (Word) > Adding Functional 
Elements to Online Content (Word) topic.

9. Note that although the cross-references display with page numbers in the source 
document, the Stationery designer configured the Stationery to display cross-
references as hyperlinks without page numbers in the generated output. Cross-
references with page numbers are appropriate in printed content, while cross-
references displayed as hyperlinks without page numbers are appropriate in online 
content.
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10. Note that each page of the generated output includes previous and next browse 
sequence buttons that automatically set the browse sequence to the same page as the 
order of topics in the table of contents. Users can use these buttons to click through 
online content in the order of the table of contents. The browse sequence buttons are 
enabled in ePublisher by default. Stationery designers can choose whether they 
want to display or hide the browse buttons when they define the Stationery. 
Stationery designers can also change the appearance of the browse sequence 
buttons in generated output.

11. Note that the generated output includes breadcrumbs. Breadcrumbs may be used to 
provide information to users about where they are in the content and to offer users a 
way to quickly return to previously viewed pages without using the Back button, 
using other navigation bars, or typing in a keyword search. Stationery designers can 
choose whether they want to display or hide breadcrumbs when they design 
Stationery. Stationery designers can also change the appearance and location of the 
breadcrumbs in generated output.

12. View how popup windows display in generated output by completing the following 
steps:

Note: Dynamic HTML does not support popup windows.

a. If you generated output using the FrameMaker source document, on the 
Contents tab, click the Popup Windows (FrameMaker) > Creating Popup 
Windows (FrameMaker) topic.

b. If you generated output using the Word source document, on the Contents 
tab, click the Popup Windows (Word) > Creating Popup Windows 
(Word) topic.

c. If you are viewing WebWorks Help output, hover over a link to display the 
popup window.

d. If you are viewing Microsoft HTML Help output, click the link to display 
the popup window.
72  Chapter 3: Exploring ePublisher Evaluation Guide



Producing Output Using Sample Source Documents and Stationery
13. View how expand/collapse sections display in generated output by completing the 
following steps:

a. If you generated output using the FrameMaker source document, on the 
Contents tab, click the Expand/Collapse Sections (FrameMaker) > 
Creating Expand/Collapse Sections (FrameMaker) topic.

b. If you generated output using the Word source document, on the Contents 
tab, click the Expand/Collapse Sections (Word) > Creating 
Expand/Collapse Sections (Word).

a. Click on the arrow following the procedure introductory text to expand and 
display the steps in the procedure.

b. Click on the arrow following the procedure introductory text again to 
collapse and hide the steps in the procedure.

14. View how related topics links display in generated output by completing the 
following steps:

a If you generated output using the FrameMaker source document, on the 
Contents tab, click the Related Topics Links (FrameMaker) > Creating 
Related Topics Links (FrameMaker) topic.

b. If you generated output using the Word source document, on the Contents 
tab, click the Related Topics Links (Word) > Creating Related Topics 
Links (Word).

c. If you are viewing related topics in WebWorks Help or Microsoft HTML 
Help, click the Related Topics button at the bottom of the page. Related 
topic links display in a related topics window, and you can click a related 
topics link in the related topics window to display the related topic.

d. If you are viewing related topics in Dynamic HTML, click a related topics 
link at the bottom of the page to display the related topic.

15. See how a context-sensitive help topic ID specified in a TopicAlias marker in a 
source document gets added to a help system mapping file by completing the 
following steps:

a. On the Project menu, select the Microsoft HTML Help - Exploring 
ePublisher target next to Active Target.

b. On the View menu, click Output Directory.

c. In the Exploring ePublisher folder, open the Exploring ePublisher.h 
mapping file in Notepad.

d. Verify that the IDH_CreatingContextSensitiveTopicsFrame or 
IDH_CreatingContextSensitiveTopicsWord topic ID is listed in the 
Exploring ePublisher.h mapping file.
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Customizing Exploring ePublisher Output

After you review the Exploring ePublisher output, customize the Exploring ePublisher 
WebWorks Help, Microsoft HTML Help, and Dynamic HTML output. This section 
provides only a few examples of some of the ways you can use ePublisher to customize 
your output. The flexible and powerful output generation capabilities ePublisher provides 
allow you to specify precisely how you want your output to display, ensuring you can 
always deliver your online content to your exact specifications every time. You can 
customize the Exploring ePublisher output by performing the following actions:

• Add your company information, such as company name, phone number, fax 
number, and email address to the generated output.

• Configure your WebWorks Help system to display the first topic in your WebWorks 
Help instead of the default WebWorks Help splash page.

• Change the theme of the WebWorks Help output.

• Hide the index in your generated output. 

In order to customize the Exploring ePublisher output, you must have target setting 
modification permissions. If you did not select the target setting permissions option when 
you installed ePublisher Express, you will not see the Target Settings menu option 
displayed on the Target menu. If you cannot see the Target Settings menu option because 
you do not have target setting modification permissions, you can quickly configure 
ePublisher Express to allow you to configure target settings. For more information, see 
“Enabling Target Setting Permissions After Installing ePublisher Express” on page 28.
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To customize Exploring ePublisher output

1. Add company information to your generated output by completing the following 
steps:

a. If you want to add company information to your WebWorks Help output, 
on the Project menu, select the WebWorks Help - Exploring ePublisher 
target next to Active Target.

b. If you want to add company information to your Microsoft HTML Help 
output, on the Project menu, select the Microsoft HTML Help - Exploring 
ePublisher target next to Active Target.

c. If you want to add company information to your Dynamic HTML output, 
on the Project menu, select the Dynamic HTML - Exploring ePublisher 
target next to Active Target.

d. On the Target menu, click Target Settings.

e. Under Company Information, in the Company email address field, type 
your company email address.

For example, type Email: info@companyname.com, where 
info@company.com is a valid email address for your company.

f. In the Company fax number field, type the fax number for your company.

For example, type Fax: xxx.xxx.xxxx, where xxx.xxx.xxxx is the fax 
number for your company.

g. In the Company name field, type your company name.

h. In the Company phone number field, type your company phone number.

For example, type Phone: xxx.xxx.xxxx, where xxx.xxx.xxxx is the phone 
number for your company.

i. In the Company web page field, type your company web page.

For example, type http://www.companyname.com, where 
www.companyname.com is the URL for your company Web site.

j. Click OK.
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2. Show the first topic instead of the splash screen in your WebWorks Help output by 
completing the following steps:

a. On the Project menu, select the WebWorks Help - Exploring ePublisher 
target next to Active Target.

b. On the Target menu, click Target Settings.

c. Under WebWorks Help, in the Show first document instead of splash 
page field, set the value to Enabled.

d. Click OK.

Your Stationery designer can also configure your Stationery to use a custom splash 
page image. For more information about customizing the splash page image, see the 
ePublisher Design Guide.  

3. Change the theme of your WebWorks Help system from Lobby Blue to Architect 
Green by completing the following steps:

a. On the Project menu, select the WebWorks Help - Exploring ePublisher 
target next to Active Target.

b. On the Target menu, click Target Settings.

c. Under WebWorks Help, in the Theme field, set the value to Architect 
Green.

d. Click OK.
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4. Hide the index in your generated output. 

By default, ePublisher creates an index using index markers inserted into source 
documents. If you have source documents that do not contain index entries, you can 
hide the index in your generated output. After you add index entries into your 
source documents, you can then specify that you want to display an index in your 
generated output in just a few clicks. The Exploring ePublisher source documents 
do not have index entries added, so you should hide the index in the Exploring 
ePublisher generated output since the index in the generated output will not contain 
useful information to users. Hide the index in your generated output by completing 
the following steps:

a. If you want to hide the index in your WebWorks Help output, on the Project 
menu, select the WebWorks Help - Exploring ePublisher target next to 
Active Target.

a. If you want to hide the index in your Microsoft HTML Help output, on the 
Project menu, select the Microsoft HTML Help - Exploring ePublisher 
target next to Active Target.

a. If you want to hide the index in your Dynamic HTML output, on the 
Project menu, select the Dynamic HTML - Exploring ePublisher target 
next to Active Target.

b. On the Target menu, click Target Settings.

c. Under Index, set the Generate index setting value to Disabled.

d. Click OK.

5. On the Project menu, click Generate All.
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6. Verify your output displays the company information you specified by completing 
the following steps:

a. If you added company information to your WebWorks Help output, on the 
Project menu, select the WebWorks Help - Exploring ePublisher target 
next to Active Target.

b. If you added company information to your Microsoft HTML Help output, 
on the Project menu, select the Microsoft HTML Help - Exploring 
ePublisher target next to Active Target.

c. If you added company information to your Dynamic HTML output, on the 
Project menu, select the Dynamic HTML - Exploring ePublisher target 
next to Active Target.

d. In Document Manager, select the Exploring ePublisher top-level group.

e. In Output Explorer, under Navigation, perform one of the following actions:

– If you added company information to your WebWorks Help output, 
double-click the index.html entry-point file to open the WebWorks 
Help system.

– If you added company information to your Microsoft HTML Help 
output, double-click the Exploring ePublisher.chm entry-point file 
to open the Microsoft HTML Help system.

– If you added company information to your Dynamic HTML output, 
double-click the toc.html entry-point file to open the Microsoft 
HTML Help system.

f. Verify that the company name, phone number, fax number, and email address 
you specified displays in the bottom right of each topic page in the generated 
output. Also note that the Stationery designer can specify a different look and 
feel for the area that contains this information as needed based on the 
preferred styles and standards for your organization.
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7. Verify that the first topic in your WebWorks Help output displays instead of the 
default WebWorks splash screen and verify that the WebWorks Help system uses 
the Architect Green theme instead of the Lobby Blue theme by completing the 
following steps:

a. On the Project menu, select the WebWorks Help - Exploring ePublisher 
target next to Active Target.

b. In Document Manager, select the Exploring ePublisher top-level group.

c. In Output Explorer, under Navigation, double-click the index.html entry-
point file to open the WebWorks Help generated output.

d. Verify that the first topic in the WebWorks Help system displays instead of 
the default WebWorks Help splash screen.

e. Verify that the color theme in the help system in the WebWorks Help system 
displays using the Architect Green theme instead of the default Lobby Blue 
theme.

8. Verify that an index no longer displays in your generated output by completing the 
following steps:

a. If you specified you wanted to hide the index in your WebWorks Help 
output, on the Project menu, select the WebWorks Help - Exploring 
ePublisher target next to Active Target.

b. If you specified you wanted to hide the index in your Microsoft HTML 
Help output, on the Project menu, select the Microsoft HTML Help - 
Exploring ePublisher target next to Active Target.

c. If you specified you wanted to hide the index in your Dynamic HTML 
output, on the Project menu, select the Dynamic HTML - Exploring 
ePublisher target next to Active Target.

d. In Document Manager, select the Exploring ePublisher top-level group.

e. In Output Explorer, under Navigation, perform one of the following actions:

– If you specified you wanted to hide the index in your WebWorks Help 
output, double-click the index.html entry-point file to open the 
WebWorks Help generated output.

– If you specified you wanted to hide the index in your Microsoft 
HTML Help output, double-click the Exploring ePublisher.chm 
entry-point file to open the Microsoft HTML Help generated output.

– If you specified you wanted to hide the index in your Dynamic 
HTML output, double-click the toc.html entry-point file to open the 
Dynamic HTML generated output.

f. Verify that the Index tab no longer displays in your generated output.
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After you perform these simple customizations for your generated output, next explore 
how you can quickly and easily implement online features using the sample Exploring 
ePublisher source documents and Stationery.

Implementing Online Features Using Sample Source Documents and 
Stationery

You can create online features such as popup windows, expand/collapse sections, and 
related topics links using the sample Exploring ePublisher source documents and 
Stationery.

Using Sample Adobe FrameMaker Source Documents and Stationery to 
Implement Online Features

If you use Adobe FrameMaker to author content, you can use the sample Exploring 
ePublisher Adobe FrameMaker source documents and the sample Exploring ePublisher 
Stationery to see how you can use ePublisher to quickly and easily implement the 
following online features:

• Popup windows

• Expand/collapse sections

• Related topics

• Context-sensitive help topics

The following procedure provides an example of how to implement online features in 
Adobe FrameMaker source documents using unstructured Adobe FrameMaker 7.2. Steps 
for implementing online features in Adobe FrameMaker may be different in other versions 
of Adobe FrameMaker.
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To implement online features using the sample Exploring ePublisher Adobe 
FrameMaker source documents and Stationery

1. Create a popup window by completing the following steps:

a. In Document Manager, open the Quick Reference.fm file.

b. In the Exploring ePublisher Sample Content section at the end of the Quick 
Reference.fm file, apply the GlossTerm paragraph format to the Popup 
window glossary term and apply the GlossDef paragraph format to the popup 
window glossary definition.

c. Insert your cursor after the period in the last sentence of the content you want 
to display in the popup window.

d. On the Special menu, click Marker.

e. In the Marker Type field, select PopupEnd from the drop-down list.

f. Click New Marker. Do not specify any text in the Marker Text field when 
you insert the marker.

g. In Document Manager, open the Creating Popup Windows.fm file.

h. In the Creating Your First Popup Window (FrameMaker) section in the 
Creating Popup Windows.fm file, highlight the term popup window in the 
following sentence:

A popup window can be used to display glossary terms and definitions.

i. On the Special menu, click Cross Reference.

j. In the Document field, select Quick Reference.fm.

k. In the Paragraph Tags field, click GlossTerm.

l. In the Paragraphs field, click Popup windows.

m. In the Format field, select Glossary Term.

n. Click OK.

o. Save your FrameMaker source document.

p. In ePublisher Express, on the Project menu, select the WebWorks Help - 
Exploring ePublisher target next to Active Target.

q. On the Project menu, click Generate All.

r. In Document Manager, select the Exploring ePublisher top-level group.

s. In Output Explorer, under Navigation, double-click the index.html file to 
open your generated WebWorks Help output.

t. On the Contents tab, click Popup Windows (FrameMaker) > Creating 
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Your First Popup Window (FrameMaker).

u. Hover over the link and verify that a popup window with the popup window 
glossary definition you specified displays correctly.

2. Create an expand/collapse section by completing the following steps:

a. In Document Manager, open the Creating Expand Collapse Sections.fm 
file.

b. In the Creating Your First Expand/Collapse Section (FrameMaker) section, 
apply the ExpandCollapse paragraph format to the following text:

To create your first expand/collapse section

c. Insert your cursor after the period in the last sentence of the procedure.

d. On the Special menu, click Marker.

e. In the Marker Type field, select DropDownEnd from the drop-down list.

f. Click New Marker. Do not specify any text in the Marker Text field when 
you insert the marker.

g. Save the Adobe FrameMaker source document.

h. In ePublisher Express, on the Project menu, select the WebWorks Help - 
Exploring ePublisher target next to Active Target.

i. On the Project menu, click Generate All.

j. In Document Manager, select the Exploring ePublisher top-level group.

k. In Output Explorer, under Navigation, double-click the index.html file to 
open your generated WebWorks Help output.

l. On the Contents tab, click Expand/Collapse Sections (FrameMaker) > 
Creating Your First Expand/Collapse Section (FrameMaker).

m. Click on the arrow following the procedure introductory text to expand and 
display the steps in the procedure.

n. Click on the arrow following the procedure introductory text again to 
collapse and hide the steps in the procedure.
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3. Create related topics links for a topic by completing the following steps:

a. In Document Manager, open the Creating Related Topics.fm file.

b. In the Creating Your First Related Topics Links (FrameMaker) section, apply 
the RelatedTopic paragraph format to the following list of cross-references at 
the end of the topic:

– Creating Your First Popup Window (FrameMaker)

– Creating Your First Expand/Collapse Section (FrameMaker)

c. Save the Adobe FrameMaker source document.

d. In ePublisher Express, on the Project menu, select the WebWorks Help - 
Exploring ePublisher target next to Active Target.

e. On the Project menu, click Generate All.

f. In Document Manager, select the Exploring ePublisher top-level group.

g. In Output Explorer, under Navigation, double-click the index.html file to 
open your generated WebWorks Help output.

h. On the Contents tab, click Related Topics Links (FrameMaker) > 
Creating Your First Related Topics Links (FrameMaker).

i. Click on the Related Topics button at the bottom of the page and verify that 
the list of related topics displays in the generated output.
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4. Create a context-sensitive help topic by completing the following steps:

a. In Document Manager, open the Creating Context Sensitive Topics.fm 
file.

b. In the Creating Your First Context-Sensitive Help Topics (FrameMaker) 
section, insert your cursor in front of the first paragraph in the topic.

c. On the Special menu, click Marker.

d. In the Marker Type field, select TopicAlias from the drop-down list.

e. In the Marker Text field, specify the following topic ID for the topic:

IDH_CreatingYourFirstContextSensitiveHelpTopicFrame

f. Click New Marker. 

g. Save the Adobe FrameMaker source document.

h. On the Project menu, select the Microsoft HTML Help - Exploring 
ePublisher target next to Active Target.

i. On the Project menu, click Generate All.

j. On the View menu, click Output Directory.

k. In the Exploring ePublisher folder, open the Exploring ePublisher.h 
mapping file in Notepad.

l. Verify that the 
IDH_CreatingYourFirstContextSensitiveHelpTopicFrame topic ID is 
listed in the Exploring ePublisher.h mapping file.

Using Sample Microsoft Word Source Documents and Stationery to 
Implement Online Features

If you use Microsoft Word to author content, you can use the sample Exploring ePublisher 
Microsoft Word source document and the sample Exploring ePublisher Stationery to see 
how you can use ePublisher to quickly and easily implement the following online features:

• Popup windows

• Expand/collapse sections

• Related topics

• Context-sensitive help topics

The following procedure provides an example of how to implement online features in 
Microsoft Word source documents using Microsoft Word 2003. Steps for implementing 
online features in Microsoft Word may be different in other versions of Microsoft Word.
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To implement online features using the sample Exploring ePublisher 
Microsoft Word source documents and Stationery

1. Create a popup window by completing the following steps:

a. In Document Manager, open the Exploring ePublisher.doc file.

b. In the Exploring ePublisher Sample Content (Word) section at the end of the 
Exploring ePublisher.doc file, apply the GlossTerm paragraph format to 
the Popup window glossary term and apply the GlossDef paragraph format to 
the popup window glossary definition.

c. Insert your cursor in front of the Popup window term.

d. On the Insert menu, click Bookmark.

e. In the Bookmark name field, type PopupWindow, and then click Add.

f. Insert your cursor at the end of the last sentence of the popup window 
definition.

g. On the WebWorks menu, click Markers.

h. In the Marker field, select PopupEnd, and then click OK.

i. In the Creating Your First Popup Window (Word) section in the Exploring 
ePublisher.doc file, highlight the term popup window in the following 
sentence:

A popup window can be used to display glossary terms and definitions.

j. On the Insert menu, click Hyperlink.

k. In the Select a place in this document field, under Bookmarks, select 
PopupWindow, and then click OK.

l. Save your Word source document.

m. In ePublisher Express, on the Project menu, select the WebWorks Help - 
Exploring ePublisher target next to Active Target.

n. On the Project menu, click Generate All.

o. In Document Manager, select the Exploring ePublisher top-level group.

p. In Output Explorer, under Navigation, double-click the index.html file to 
open your generated WebWorks Help output.

q. On the Contents tab, click Popup Windows (Word) > Creating Your First 
Popup Window (Word).

r. Hover over the popup window text in the following sentence and verify that a 
popup window with the popup window glossary definition you specified 
displays correctly.
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2. Create an expand/collapse section by completing the following steps:

a. In the Creating Your First Expand/Collapse Section (Word) section in the 
Exploring ePublisher.doc source document, apply the ExpandCollapse 
paragraph format to the following text:

To create your first expand/collapse section

b. Insert your cursor after the period in the last sentence of the procedure.

c. On the WebWorks menu, click Markers.

d. In the Marker field, select DropDownEnd from the list, and then click OK.

e. Save the Microsoft Word source document.

f. In ePublisher Express, on the Project menu, select the WebWorks Help - 
Exploring ePublisher target next to Active Target.

g. On the Project menu, click Generate All.

h. In Document Manager, select the Exploring ePublisher top-level group.

i. In Output Explorer, under Navigation, double-click the index.html file to 
open your generated WebWorks Help output.

j. On the Contents tab, click Expand/Collapse Sections (Word) > Creating 
Your First Expand/Collapse Section (Word).

k. Click on the arrow following the procedure introductory text to expand and 
display the steps in the procedure.

l. Click on the arrow following the procedure introductory text again to 
collapse and hide the steps in the procedure.
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3. Create related topics links for a topic by completing the following steps:

a. In the Creating Your First Related Topics Links (Word) section in the 
Exploring ePublisher.doc source document, apply the RelatedTopic 
paragraph format to the following list of cross-references at the end of the 
topic:

– Creating Your First Popup Window (Word)

– Creating Your First Expand/Collapse Section (Word)

b. Save the Microsoft Word source document.

c. In ePublisher Express, on the Project menu, select the WebWorks Help - 
Exploring ePublisher target next to Active Target.

d. On the Project menu, click Generate All.

e. In Document Manager, select the Exploring ePublisher top-level group.

f. In Output Explorer, under Navigation, double-click the index.html file to 
open your generated WebWorks Help output.

g. On the Contents tab, click Related Topics Links (Word) > Creating Your 
First Related Topics Links (Word).

h. Click on the Related Topics button at the bottom of the page and verify that 
the list of related topics displays in the generated output.
Evaluation Guide Chapter 3: Exploring ePublisher  87



Exploring Additional ePublisher Capabilities
4. Create a context-sensitive help topic by completing the following steps:

a. In the Creating Your First Context-Sensitive Help Topics section in the 
Exploring ePublisher.doc source document, insert your cursor in front of 
the first paragraph in the topic.

b. On the WebWorks menu, click Insert TopicAlias Marker.

c. In the Topic Alias field, specify the following topic ID for the topic:

IDH_CreatingYourFirstContextSensitiveHelpTopicWord 

d. Click OK. 

e. Save the Microsoft Word source document.

f. On the Project menu, select the Microsoft HTML Help - Exploring 
ePublisher target next to Active Target.

g. On the Project menu, click Generate All.

h. On the View menu, click Output Directory.

i. In the Exploring ePublisher folder, open the Exploring ePublisher.h 
mapping file in Notepad.

j. Verify that the IDH_CreatingYourFirstContextSensitiveHelpTopicWord 
topic ID is listed in the Exploring ePublisher.h mapping file.

Exploring Additional ePublisher Capabilities

The sample Exploring ePublisher source documents and Stationery provide only a small 
sample of some of the many capabilities ePublisher provides.

You can view additional multimedia recordings on the WebWorks Web site that illustrate a 
wide range of other ePublisher capabilities, such as producing Eclipse Help, Wiki markup, 
PDFs, and Dynamic HTML Web site output, how you can use ePublisher to precisely 
customize the look and feel of your generated output to meet corporate and branding 
requirements, and more.

See the full list of Exploring ePublisher videos at: 
www.webworks.com/Resources/Video_Library. 
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Customizing Your ePublisher Workspace

By default, the ePublisher user interface comes preset with certain toolbar icons and 
window settings. ePublisher gives you extensive control over the appearance of the user 
interface by allowing you to customize the display of windows and toolbars. 

When you open ePublisher for the first time, Document Manager and Output Explorer are 
docked and the Log Window is undocked. When a window is undocked, it displays as a 
tab in the sidebar, and it will auto-hide unless you hover over the tab in the sidebar. When 
you hover over an undocked window, the window displays. 

You can customize the display of windows in the user interface to suit your needs. In 
ePublisher, you can move Document Manager, Output Explorer, and the Log Window to 
different locations within the user interface or make them into floating windows. When 
you dock a window, it becomes stationary within the user interface and is always visible. 

You can rearrange docked windows by moving the window to a new location within the 
user interface. For example, you can move the Output Explorer into a new window pane 
next to the Start page. However, the Start page cannot be moved. The Start page serves as 
the central point from which all the windows are arranged. To move a docked window 
within the user interface, click on the title bar of the window and then drag the window to 
a new location. To undock a window, click on the pin icon in the upper right corner of the 
window.

In addition to rearranging docked windows, you can add, remove, customize, or create 
buttons on tool bars. You can also create your own custom toolbars. By customizing your 
toolbars and buttons, you can create a workspace that fits your preferences and work style.

Whenever you make changes to the user interface by moving windows, changing window 
dock settings, or customizing toolbars, the changes take effect for each subsequent project 
you create or open. For example, if you dock Document Manager, Output Explorer, and 
the Log Window and add customized buttons to the toolbar, these settings will become the 
default settings for each project you open.

Specifying General ePublisher Preferences 

You use the General tab of the Preferences window to specify ePublisher preferences, 
such as the number of recent projects to display on the Start page, whether to 
automatically scan source documents when you add them to Document Manager, and 
where to store user-created formats. You can also reset the user interface toolbar and 
window dock positions.
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To specify general ePublisher preferences

1. On the Edit menu, click Preferences.

2. Specify preferences for each setting. For more information about settings and 
options, click Help. 
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