Table of Contents



Upgrading Implementations with Advanced Customizations

If you have implemented advanced overrides in the Stationery design, such as overrides to .xsl or.fti files, or overrides to files in the Formats folder, ensure you save a copy of the following items to a secure location before uninstalling a previous version of ePublisher and installing a new version:

If you want to continue to use your advanced customizations with the new version of ePublisher, first uninstall your previous ePublisher version and then install a new ePublisher version. Then identify and include your overrides in the new versions of the ePublisher files as appropriate by performing a three-way merge of the following items:

Performing a three-way merge allows you to identify the code you changed when you created the override, and also allows you to quickly and easily create the override again in the new ePublisher files. You may find tools such as Araxis Merge Pro, available at, or KDiff3, available at, helpful as you compare and merge override files.

After you perform your three-way merge and update the files you want to override in the new version of ePublisher with the overrides you specified in the previous version, test your overrides by generating output using the new version of ePublisher Pro and the Stationery design project to confirm your output generates appropriately. After you verify the output generated correctly using your advanced customizations, you can create new Stationery using the Stationery design project and then deploy the updated Stationery that includes your advanced customizations to writers to use to generate output.

ePublisher/2009.2/Help/01.Welcome_to_ePublisher/5.41.Planning_and_Installing (last edited 2009-08-03 19:08:54 by TonyMcDow)